Hi, Andrew, On Sat, May 13, 2023 at 7:53 AM Andrew Morton <akpm@xxxxxxxxxxxxxxxxxxxx> wrote: > > On Tue, 9 May 2023 18:41:27 +0800 Huacai Chen <chenhuacai@xxxxxxxxxxx> wrote: > > > Commit 343f4c49f2438d8 ("kthread: Don't allocate kthread_struct for init > > and umh") introduces a new function user_mode_thread() for init and umh. > > But the name is a bit confusing because init and umh are indeed kernel > > threads at creation time, the real difference is "they will become user > > processes". So let's unify the kernel_thread() and user_mode_thread() to > > kernel_thread() again, and add a new 'user' parameter for init and umh. > > > > ... > > > > 5 files changed, 9 insertions(+), 26 deletions(-) > > > > Less code is nice. > > > -extern pid_t user_mode_thread(int (*fn)(void *), void *arg, unsigned long flags); > > + unsigned long flags, int user); > > `bool user'? OK, I will do that in the next version if the whole patch is acceptable. Huacai > >