Hello there, >It should be fine here. Perhaps I have been slightly less than clear. The discussion is about the *style* of the code, *not* whether it works or not. My apologies for the lack of clarity. Expression is while (A && B && C) The static analyser notices it is poor style to have B do a limit check, but have A use it. Sure its working code, but suggest new code while (B && A && C) It won't make much difference to the code, it will merely be better style. 2. >> Source code is >> >> memset(pivs + tmp, 0, >> sizeof(unsigned long *) * (max_p - tmp)); >It's not good here, I can fix it. sizeof( pivs[ 0]) is a better thing to say than sizeof( unsigned long). There is reduced future maintenance burden, when the type of *pivs changes. Regards David Binderman