On 11/04/2023 17:14, Aneesh Kumar K V wrote: > On 4/11/23 9:22 PM, Joao Martins wrote: >> [subject line should be mm/hugetlb as opposed to m/hugetlb] >> >> On 11/04/2023 15:18, Aneesh Kumar K.V wrote: >>> Now we use ARCH_WANT_HUGETLB_PAGE_OPTIMIZE_VMEMMAP config option >>> to indicate devdax and hugetlb vmemmap optimization support. Hence >>> rename that to a generic ARCH_WANT_OPTIMIZE_VMEMMAP >>> >>> Cc: Joao Martins <joao.m.martins@xxxxxxxxxx> >>> Cc: Muchun Song <songmuchun@xxxxxxxxxxxxx> >>> Cc: Dan Williams <dan.j.williams@xxxxxxxxx> >>> Signed-off-by: Aneesh Kumar K.V <aneesh.kumar@xxxxxxxxxxxxx> >> >> +Mike from hugetlb >> >>> --- >>> arch/arm64/Kconfig | 2 +- >>> arch/loongarch/Kconfig | 2 +- >>> arch/s390/Kconfig | 2 +- >>> arch/x86/Kconfig | 2 +- >>> fs/Kconfig | 9 +-------- >>> include/linux/mm.h | 2 +- >>> mm/Kconfig | 6 ++++++ >>> 7 files changed, 12 insertions(+), 13 deletions(-) >>> >>> diff --git a/arch/arm64/Kconfig b/arch/arm64/Kconfig >>> index 27b2592698b0..77d9713dcd9c 100644 >>> --- a/arch/arm64/Kconfig >>> +++ b/arch/arm64/Kconfig >>> @@ -100,9 +100,9 @@ config ARM64 >>> select ARCH_WANT_DEFAULT_TOPDOWN_MMAP_LAYOUT >>> select ARCH_WANT_FRAME_POINTERS >>> select ARCH_WANT_HUGE_PMD_SHARE if ARM64_4K_PAGES || (ARM64_16K_PAGES && !ARM64_VA_BITS_36) >>> - select ARCH_WANT_HUGETLB_PAGE_OPTIMIZE_VMEMMAP >>> select ARCH_WANT_LD_ORPHAN_WARN >>> select ARCH_WANTS_NO_INSTR >>> + select ARCH_WANT_OPTIMIZE_VMEMMAP >> >> Why don't you just change the line you just deleted? >> > > Those config select statements are sorted? /me facepalm Totally missed that.