> + bio_for_each_folio_all(fi, bio) { > + if (!err) > + folio_mark_uptodate(fi.folio); > + else > + folio_set_error(fi.folio); > + folio_unlock(fi.folio); Super nitpicky, but I'd avoid inverted conditions unless there is a very clear benefit. I.e. I'd rather write this as: if (err) folio_set_error(fi.folio); else folio_mark_uptodate(fi.folio); Otherwise looks good: Reviewed-by: Christoph Hellwig <hch@xxxxxx>