On Fri, Mar 31, 2023 at 1:51 PM Dave Chinner <david@xxxxxxxxxxxxx> wrote: > > On Fri, Mar 31, 2023 at 07:08:17AM +0000, Yosry Ahmed wrote: > > During reclaim, we keep track of pages reclaimed from other means than > > LRU-based reclaim through scan_control->reclaim_state->reclaimed_slab, > > which we stash a pointer to in current task_struct. > > > > However, we keep track of more than just reclaimed slab pages through > > this. We also use it for clean file pages dropped through pruned inodes, > > and xfs buffer pages freed. Rename reclaimed_slab to reclaimed, and add > > a helper function that wraps updating it through current, so that future > > changes to this logic are contained within mm/vmscan.c. > > > > Signed-off-by: Yosry Ahmed <yosryahmed@xxxxxxxxxx> > ..... > > diff --git a/mm/vmscan.c b/mm/vmscan.c > > index fef7d1c0f82b2..a3e38851b34ac 100644 > > --- a/mm/vmscan.c > > +++ b/mm/vmscan.c > > @@ -511,6 +511,34 @@ static void set_task_reclaim_state(struct task_struct *task, > > task->reclaim_state = rs; > > } > > > > +/* > > + * mm_account_reclaimed_pages(): account reclaimed pages outside of LRU-based > > + * reclaim > > + * @pages: number of pages reclaimed > > + * > > + * If the current process is undergoing a reclaim operation, increment the > > + * number of reclaimed pages by @pages. > > + */ > > +void mm_account_reclaimed_pages(unsigned long pages) > > +{ > > + if (current->reclaim_state) > > + current->reclaim_state->reclaimed += pages; > > +} > > +EXPORT_SYMBOL(mm_account_reclaimed_pages); > > Shouldn't this be a static inline in a header file? > > Then you don't need an EXPORT_SYMBOL() - which should really be > EXPORT_SYMBOL_GPL() - and callers don't add the overhead of a > function call for two lines of code.... Yes it should be. Thanks. An earlier draft of this series had more going on in this function, so I moved it to mm/vmscan.c, then I forgot to move it to the header later. Will do that for v4. > > -Dave. > -- > Dave Chinner > david@xxxxxxxxxxxxx