Refactor do_fault_around() to avoid bitwise tricks and arather difficult to follow logic. Additionally, prefer fault_around_pages to fault_around_bytes as the operations are performed at a base page granularity. I have run this code against a small program I wrote which generates significant input data and compares output with the original function to ensure that it behaves the same as the old code across varying vmf, vma and fault_around_pages inputs. Lorenzo Stoakes (2): mm: refactor do_fault_around() mm: pefer fault_around_pages to fault_around_bytes mm/memory.c | 62 ++++++++++++++++++++++++++--------------------------- 1 file changed, 30 insertions(+), 32 deletions(-) -- 2.39.2