On Fri, Jan 27, 2023 at 05:12:13AM -0300, Leonardo Brás wrote: > On Fri, 2023-01-27 at 04:22 -0300, Leonardo Brás wrote: > > > Hmm, OK, I have misunderstood your proposal. Yes, the overal pcp charges > > > potentially left behind should be small and that shouldn't really be a > > > concern for memcg oom situations (unless the limit is very small and > > > workloads on isolated cpus using small hard limits is way beyond my > > > imagination). > > > > > > My first thought was that those charges could be left behind without any > > > upper bound but in reality sooner or later something should be running > > > on those cpus and if the memcg is gone the pcp cache would get refilled > > > and old charges gone. > > > > > > So yes, this is actually a better and even simpler solution. All we need > > > is something like this > > > diff --git a/mm/memcontrol.c b/mm/memcontrol.c > > > index ab457f0394ab..13b84bbd70ba 100644 > > > --- a/mm/memcontrol.c > > > +++ b/mm/memcontrol.c > > > @@ -2344,6 +2344,9 @@ static void drain_all_stock(struct mem_cgroup *root_memcg) > > > struct mem_cgroup *memcg; > > > bool flush = false; > > > > > > + if (cpu_is_isolated(cpu)) > > > + continue; > > > + > > > rcu_read_lock(); > > > memcg = stock->cached; > > > if (memcg && stock->nr_pages && > > > > > > There is no such cpu_is_isolated() AFAICS so we would need a help from > > > NOHZ and cpuisol people to create one for us. Frederic, would such an > > > abstraction make any sense from your POV? > > > > > > IIUC, 'if (cpu_is_isolated())' would be instead: > > > > if (!housekeeping_cpu(smp_processor_id(), HK_TYPE_DOMAIN) || > > !housekeeping_cpu(smp_processor_id(), HK_TYPE_WQ) > > oh, sorry 's/smp_processor_id()/cpu/' here: > > if(!housekeeping_cpu(cpu, HK_TYPE_DOMAIN) || !housekeeping_cpu(cpu, HK_TYPE_WQ)) Do you also need to handle cpuset.sched_load_balance=0 (aka. cpuset v2 "isolated" partition type). It has the same effect as isolcpus=, but it can be changed at runtime. And then on_null_domain() look like what you need. You'd have to make that API more generally available though, and rename it to something like "bool cpu_has_null_domain(int cpu)". But then you also need to handle concurrent cpuset changes. If you can tolerate it to be racy, then RCU alone is fine. Thanks.