On Wed, Jan 25, 2023 at 03:35:51PM -0800, Suren Baghdasaryan wrote: > Replace direct modifications to vma->vm_flags with calls to modifier > functions to be able to track flag changes and to keep vma locking > correctness. > > Signed-off-by: Suren Baghdasaryan <surenb@xxxxxxxxxx> > Acked-by: Michal Hocko <mhocko@xxxxxxxx> Acked-by: Mel Gorman <mgorman@xxxxxxxxxxxxxxxxxxx> Minor comments that are safe to ignore. I think a better name for mod_vm_flags is set_clear_vm_flags to hint that the first flags are to be set and the second flags are to be cleared. For this patch, it doesn't matter, but it might avoid accidental swapping in the future. reset_vm_flags might also be better named as reinit_vma_flags (or vma_flags_reinit). Maybe also encourage the use of [set|clear_mod]_vm_flags where possible in the comment to track exactly what is changing and why. Some cases like userfaultfd just want to clear __VM_UFFD_FLAGS but altering the flow in this patch is inappropriate and error prone. Others such as the infiniband changes and madvise are a lot more complex. -- Mel Gorman SUSE Labs