* Vernon Yang <vernon2gm@xxxxxxxxx> [221221 01:01]: > Hello, > > This patchset clean up and refinement some maple tree code, a few small > changes make the code easier to understand and for better readability. > > v2 changes: > - Add Reviewed-by Liam R. Howlett to all patches besides 6 & 8. > - Remove patch 6. > - Add an unlikely() to the if statement for patch 8. > > v1: https://lore.kernel.org/linux-mm/20221220140829.1665432-1-vernon2gm@xxxxxxxxx/ Reviewed-by: Liam R. Howlett <Liam.Howlett@xxxxxxxxxx> > > Vernon Yang (7): > maple_tree: remove extra space and blank line > maple_tree: remove extra return statement > maple_tree: use mt_node_max() instead of direct operations mt_max[] > maple_tree: use macro MA_ROOT_PARENT instead of number > maple_tree: remove the redundant code > maple_tree: refine ma_state init from mas_start() > maple_tree: refine mab_calc_split function > > include/linux/maple_tree.h | 6 ------ > lib/maple_tree.c | 35 ++++++++++++----------------------- > 2 files changed, 12 insertions(+), 29 deletions(-) > > -- > 2.34.1 >