On Tue, 13 Dec 2022 17:27:29 +0800 Kefeng Wang <wangkefeng.wang@xxxxxxxxxx> wrote: > This change and rename all page related function to use folio, > which save many compound_head() calls and kernel text. > > Signed-off-by: Kefeng Wang <wangkefeng.wang@xxxxxxxxxx> > --- > mm/page_idle.c | 91 ++++++++++++++++++++++++-------------------------- > 1 file changed, 44 insertions(+), 47 deletions(-) > > diff --git a/mm/page_idle.c b/mm/page_idle.c > index bc08332a609c..38641f94cf49 100644 > --- a/mm/page_idle.c > +++ b/mm/page_idle.c > @@ -19,34 +19,33 @@ > #define BITMAP_CHUNK_BITS (BITMAP_CHUNK_SIZE * BITS_PER_BYTE) > > /* > - * Idle page tracking only considers user memory pages, for other types of > - * pages the idle flag is always unset and an attempt to set it is silently > + * Idle folio tracking only considers user memory folios, for other types of > + * folios the idle flag is always unset and an attempt to set it is silently > * ignored. I think this might make future readers confused, as the code and comments will call this subsystem as Idle _folio_ tracking while the user interface and the document calls it as Idle _page_ tracking. > * > - * We treat a page as a user memory page if it is on an LRU list, because it is > - * always safe to pass such a page to rmap_walk(), which is essential for idle > - * page tracking. With such an indicator of user pages we can skip isolated > - * pages, but since there are not usually many of them, it will hardly affect > + * We treat a folio as a user memory folio if it is on an LRU list, because it is > + * always safe to pass such a folio to rmap_walk(), which is essential for idle > + * folio tracking. With such an indicator of user folios we can skip isolated > + * folios, but since there are not usually many of them, it will hardly affect > * the overall result. > * > - * This function tries to get a user memory page by pfn as described above. > + * This function tries to get a user memory folio by pfn as described above. > */ > -static struct page *page_idle_get_page(unsigned long pfn) > +static struct folio *folio_idle_get_folio(unsigned long pfn) > { > - struct page *page = pfn_to_online_page(pfn); > + struct folio *folio = pfn_to_online_folio(pfn); > > - if (!page || !PageLRU(page) || > - !get_page_unless_zero(page)) > + if (!folio || !folio_test_lru(folio) || !folio_try_get(folio)) > return NULL; As Matthew also mentioned, you changed the behavior. It looks like a right behavior if we call this function folio_idle_get_folio(), but it shouldn't. page_idle_get_folio() would be a better name in my humble opinion. So, unless we're gonna change the behavior of this subsystem (which wouldn't be the case as it would break users), I think it would be better to keep the name of this subsystem as Idle page tracking and avoid unnecessary renaming changes. Thanks, SJ