On Wed, Dec 07, 2022 at 10:34:31AM +0800, Kefeng Wang wrote: > @@ -402,7 +402,7 @@ extern void lru_add_drain_cpu(int cpu); > extern void lru_add_drain_cpu_zone(struct zone *zone); > extern void lru_add_drain_all(void); > extern void deactivate_page(struct page *page); > -extern void mark_page_lazyfree(struct page *page); > +extern void mark_folio_lazyfree(struct folio *folio); > extern void swap_setup(void); Can we rename this function to folio_mark_lazyfree() instead so it's more consistent with other the folio functions. Also I believe we can get rid of the 'extern' keyword.