On Wed, Nov 16, 2022 at 2:02 PM Peter Xu <peterx@xxxxxxxxxx> wrote: > > On Fri, Oct 21, 2022 at 04:36:28PM +0000, James Houghton wrote: > > +/* hugetlb_hgm_walk - walks a high-granularity HugeTLB page table to resolve > > + * the page table entry for @addr. > > + * > > + * @hpte must always be pointing at an hstate-level PTE (or deeper). > > + * > > + * This function will never walk further if it encounters a PTE of a size > > + * less than or equal to @sz. > > + * > > + * @stop_at_none determines what we do when we encounter an empty PTE. > > IIUC it is not about empty PTE but swap-or-empty pte? > > I'm not sure whether it'll be more straightforward to have "bool alloc" > just to show whether the caller would like to allocate pgtables when > walking the sub-level pgtable until the level specified. I think "bool alloc" is cleaner. I'll do that. Thanks for the suggestion. > > In final version of the code I also think we should drop all the "/* > stop_at_pte */" comments in the callers. Maybe that already means the > meaning of the bool is confusing so we always need a hint. I did that to hopefully make things easier to read. I'll remove it. - James > > -- > Peter Xu >