On Wed, Nov 16, 2022 at 2:18 PM Peter Xu <peterx@xxxxxxxxxx> wrote: > > On Fri, Oct 21, 2022 at 04:36:26PM +0000, James Houghton wrote: > > +struct hugetlb_pte { > > + pte_t *ptep; > > + unsigned int shift; > > + enum hugetlb_level level; > > + spinlock_t *ptl; > > +}; > > Do we need both shift + level? Maybe it's only meaningful for ARM where > the shift may not be directly calculcated from level? > > I'm wondering whether we can just maintain "shift" then we calculate > "level" realtime. It just reads a bit weird to have these two fields, also > a burden to most of the call sites where shift and level exactly match.. My main concern is interaction with folded levels. For example, if PUD_SIZE and PMD_SIZE are the same, we want to do something like this: pud = pud_offset(p4d, addr) pmd = pmd_offset(pud, addr) /* this is just pmd = (pmd_t *) pud */ pte = pte_offset(pmd, addr) and I think we should avoid quietly skipping the folded level, which could happen: pud = pud_offset(p4d, addr) /* Each time, we go back to pte_t *, so if we stored PUD_SHIFT here, it is impossible to know that `pud` came from `pud_offset` and not `pmd_offset`. We must assume the deeper level so that we don't get stuck in a loop. */ pte = pte_offset(pud, addr) /* pud is cast from (pud_t * -> pte_t * -> pmd_t *) */ Quietly dropping p*d_offset for folded levels is safe; it's just a cast that we're doing anyway. If you think this is fine, then I can remove `level`. It might also be that this is a non-issue and that there will never be a folded level underneath a hugepage level. We could also change `ptep` to a union eventually (to clean up "hugetlb casts everything to pte_t *" messiness), and having an explicit `level` as a tag for the union would be nice help. In the same way: I like having `level` explicitly so that we know for sure where `ptep` came from. I can try to reduce the burden at the callsite while keeping `level`: hpage_size_to_level() is really annoying to have everywhere. > > > + > > +static inline > > +void hugetlb_pte_populate(struct hugetlb_pte *hpte, pte_t *ptep, > > + unsigned int shift, enum hugetlb_level level) > > I'd think it's nicer to replace "populate" with something else, as populate > is definitely a meaningful word in vm world for "making something appear if > it wasn't". Maybe hugetlb_pte_setup()? > > Even one step back, on the naming of hugetlb_pte.. Sorry to comment on > namings especially on this one, I really don't like to do that normally.. > but here hugetlb_pte only walks the sub-page level of pgtables, meanwhile > it's not really a pte but an iterator. How about hugetlb_hgm_iter? "hgm" > tells that it only walks sub-level, and "iter" tells that it is an > iterator, being updated for each stepping downwards. > > Then hugetlb_pte_populate() can be hugetlb_hgm_iter_init(). > > Take these comments with a grain of salt, and it never hurts to wait for a > 2nd opinion before anything. I think this is a great idea. :) Thank you! I'll make this change for v1 unless someone has a better suggestion. > > > +{ > > + WARN_ON_ONCE(!ptep); > > + hpte->ptep = ptep; > > + hpte->shift = shift; > > + hpte->level = level; > > + hpte->ptl = NULL; > > +} > > + > > +static inline > > +unsigned long hugetlb_pte_size(const struct hugetlb_pte *hpte) > > +{ > > + WARN_ON_ONCE(!hpte->ptep); > > + return 1UL << hpte->shift; > > +} > > + > > +static inline > > +unsigned long hugetlb_pte_mask(const struct hugetlb_pte *hpte) > > +{ > > + WARN_ON_ONCE(!hpte->ptep); > > + return ~(hugetlb_pte_size(hpte) - 1); > > +} > > + > > +static inline > > +unsigned int hugetlb_pte_shift(const struct hugetlb_pte *hpte) > > +{ > > + WARN_ON_ONCE(!hpte->ptep); > > + return hpte->shift; > > +} > > + > > +static inline > > +enum hugetlb_level hugetlb_pte_level(const struct hugetlb_pte *hpte) > > +{ > > + WARN_ON_ONCE(!hpte->ptep); > > There're definitely a bunch of hpte->ptep WARN_ON_ONCE()s.. AFAIK the > hugetlb_pte* will be setup once with valid ptep and then it should always > be. I rem someone commented on these helpers look not useful, which I must > confess I had the same feeling. But besides that, I'd rather drop all > these WARN_ON_ONCE()s but only check it when init() the iterator/pte. The idea with these WARN_ON_ONCE()s is that it WARNs for the case that `hpte` was never populated/initialized, but I realize that we can't even rely on hpte->ptep == NULL. I'll remove the WARN_ON_ONCE()s, and I'll drop hugetlb_pte_shift and hugetlb_pte_level entirely. I'll keep the hugetlb_pte_{size,mask,copy,present_leaf} helpers as they are legitimately helpful. > > > + return hpte->level; > > +} > > + > > +static inline > > +void hugetlb_pte_copy(struct hugetlb_pte *dest, const struct hugetlb_pte *src) > > +{ > > + dest->ptep = src->ptep; > > + dest->shift = src->shift; > > + dest->level = src->level; > > + dest->ptl = src->ptl; > > +} > > + > > +bool hugetlb_pte_present_leaf(const struct hugetlb_pte *hpte, pte_t pte); > > + > > struct hugepage_subpool { > > spinlock_t lock; > > long count; > > @@ -1210,6 +1279,25 @@ static inline spinlock_t *huge_pte_lock(struct hstate *h, > > return ptl; > > } > > > > +static inline > > +spinlock_t *hugetlb_pte_lockptr(struct mm_struct *mm, struct hugetlb_pte *hpte) > > +{ > > + > > + BUG_ON(!hpte->ptep); > > Another BUG_ON(); better be dropped too. Can do. > > > + if (hpte->ptl) > > + return hpte->ptl; > > + return huge_pte_lockptr(hugetlb_pte_shift(hpte), mm, hpte->ptep); > > I'm curious whether we can always have hpte->ptl set for a valid > hugetlb_pte. I think that means we'll need to also init the ptl in the > init() fn of the iterator. Then it'll be clear on which lock to take for > each valid hugetlb_pte. I can work on this for v1. Right now it's not very good: for 4K PTEs, we manually set ->ptl while walking. I'll make it so that ->ptl is always populated so the code is easier to read. - James > > > +} > > -- > Peter Xu >