On 10/09/22 at 04:39pm, Christophe Leroy wrote: > > > Le 09/10/2022 à 12:31, Baoquan He a écrit : > > By taking GENERIC_IOREMAP method, the generic ioremap_prot() and > > iounmap() are visible and available to arch. Arch only needs to > > provide implementation of arch_ioremap() or arch_iounmap() if there's > > arch specific handling needed in its ioremap() or iounmap(). This > > change will simplify implementation by removing duplicated codes with > > generic ioremap() and iounmap(), and has the equivalent functioality. > > > > For hexagon, the current ioremap() and iounmap() are the same as > > generic version. After taking GENERIC_IOREMAP way, the old ioremap() > > and iounmap() can be completely removed. > > > > Signed-off-by: Baoquan He <bhe@xxxxxxxxxx> > > Cc: Brian Cain <bcain@xxxxxxxxxxx> > > Cc: Mark Brown <broonie@xxxxxxxxxx> > > Cc: Linus Walleij <linus.walleij@xxxxxxxxxx> > > Cc: linux-hexagon@xxxxxxxxxxxxxxx > > --- > > v2->v3: > > Rewrite patch log. > > Put it at the beginning of patchset since it doesn't introduce new > > arch_ioremap()/arch_iounmap(). > > > > arch/hexagon/Kconfig | 1 + > > arch/hexagon/include/asm/io.h | 9 +++++-- > > arch/hexagon/mm/ioremap.c | 44 ----------------------------------- > > 3 files changed, 8 insertions(+), 46 deletions(-) > > delete mode 100644 arch/hexagon/mm/ioremap.c > > > > diff --git a/arch/hexagon/Kconfig b/arch/hexagon/Kconfig > > index 54eadf265178..17afffde1a7f 100644 > > --- a/arch/hexagon/Kconfig > > +++ b/arch/hexagon/Kconfig > > @@ -25,6 +25,7 @@ config HEXAGON > > select NEED_SG_DMA_LENGTH > > select NO_IOPORT_MAP > > select GENERIC_IOMAP > > + select GENERIC_IOREMAP > > select GENERIC_SMP_IDLE_THREAD > > select STACKTRACE_SUPPORT > > select GENERIC_CLOCKEVENTS_BROADCAST > > diff --git a/arch/hexagon/include/asm/io.h b/arch/hexagon/include/asm/io.h > > index 46a099de85b7..dcd9cbbf5934 100644 > > --- a/arch/hexagon/include/asm/io.h > > +++ b/arch/hexagon/include/asm/io.h > > @@ -170,8 +170,13 @@ static inline void writel(u32 data, volatile void __iomem *addr) > > #define writew_relaxed __raw_writew > > #define writel_relaxed __raw_writel > > > > -void __iomem *ioremap(unsigned long phys_addr, unsigned long size); > > -#define ioremap_uc(X, Y) ioremap((X), (Y)) > > +/* > > + * I/O memory mapping functions. > > + */ > > +#define _PAGE_IOREMAP (_PAGE_PRESENT | _PAGE_READ | _PAGE_WRITE | \ > > + (__HEXAGON_C_DEV << 6)) > > + > > +#define ioremap_uc(addr, size) ioremap((addr), (size)) > > Why do you need to change this macro ? I don't like the X, Y since they look meaningless. I can change back if you like the old one. Thanks for checking.