Re: [PATCH v1] mm/damon: add DAMON_OBJ macro

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Hi Xin,

On Wed, 21 Sep 2022 11:49:42 +0800 Xin Hao <xhao@xxxxxxxxxxxxxxxxx> wrote:

> In damon/sysfs.c file, we use 'container_of' macro to get
> damon_sysfs_xxx struct instances, but i think it has a little
> inconvenience, because we have to pass three arguments to
> 'container_of', and the codes also look a bit long, so there i add a
> 'DAMON_OBJ' macro, you just need to pass one arguments, then you can get
> the right damon_sysfs_xxx struct instance.

Thank you always for your helps and efforts, but I have some comments below.

> 
> Signed-off-by: Xin Hao <xhao@xxxxxxxxxxxxxxxxx>
> ---
>  include/linux/damon.h |   7 ++
>  mm/damon/sysfs.c      | 230 +++++++++++++++++-------------------------
>  2 files changed, 102 insertions(+), 135 deletions(-)
> 
> diff --git a/include/linux/damon.h b/include/linux/damon.h
> index e7808a84675f..a3b577677caa 100644
> --- a/include/linux/damon.h
> +++ b/include/linux/damon.h
> @@ -24,6 +24,13 @@ static inline unsigned long damon_rand(unsigned long l, unsigned long r)
>  	return l + prandom_u32_max(r - l);
>  }
>  
> +/*
> + * Get damon_sysfs_xxx relative struct instance.
> + */
> +#define DAMON_OBJ(_type) ({						\
> +	const typeof(((struct _type *)0)->kobj)*__mptr = (kobj);	\
> +	(struct _type *)((char *)__mptr - offsetof(struct _type, kobj)); })
> +

So, this macro assumes two implicit rules.
1. The caller would have a relevant 'struct kobject *' variable called 'kobj',
   and
2. The '_type' would have the field 'kobj'.

I think the implicit rules could make some people confused, so would be better
to be well documented.  Even though those are well documented, I think it
cannot intuitively read by everyone.  Making the name better self-explaining
might help, but then the length of the code would be not so different.

So IMHO, this change makes the code a little bit shorter but unclear to
understand what it does.  And at least to my humble eyes, use of
'container_of()' makes the code a little bit more verbose, but clear to
understand.  I have no idea how we can make this code shorter while keeping it
still easily understandable, and I think the level of verboseness is acceptable
for the readability.  So Nack at the moment, sorry.


Thanks,
SJ

[...]




[Index of Archives]     [Linux ARM Kernel]     [Linux ARM]     [Linux Omap]     [Fedora ARM]     [IETF Annouce]     [Bugtraq]     [Linux OMAP]     [Linux MIPS]     [eCos]     [Asterisk Internet PBX]     [Linux API]

  Powered by Linux