On Fri, Sep 09, 2022 at 05:24:49PM +0800, Miaohe Lin wrote: > There's no need to check whether order > PAGE_ALLOC_COSTLY_ORDER again. > Minor readability improvement. > > Signed-off-by: Miaohe Lin <linmiaohe@xxxxxxxxxx> Reviewed-by: Oscar Salvador <osalvador@xxxxxxx> > --- > mm/page_alloc.c | 2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) > > diff --git a/mm/page_alloc.c b/mm/page_alloc.c > index 63ad25e86010..262e8972e019 100644 > --- a/mm/page_alloc.c > +++ b/mm/page_alloc.c > @@ -5272,7 +5272,7 @@ __alloc_pages_slowpath(gfp_t gfp_mask, unsigned int order, > * so that we can identify them and convert them to something > * else. > */ > - WARN_ON_ONCE_GFP(order > PAGE_ALLOC_COSTLY_ORDER, gfp_mask); > + WARN_ON_ONCE_GFP(costly_order, gfp_mask); > > /* > * Help non-failing allocations by giving them access to memory > -- > 2.23.0 > -- Oscar Salvador SUSE Labs