On Sat, Sep 10, 2022 at 05:34:02AM -0600, Jens Axboe wrote: > > /* Start the actual read. The read will unlock the page. */ > > + if (unlikely(workingset)) > > + psi_memstall_enter(&pflags); > > error = filler(file, folio); > > + if (unlikely(workingset)) > > + psi_memstall_leave(&pflags); > > if (error) > > return error; > > I think this would read better as: > > /* Start the actual read. The read will unlock the page. */ > if (unlikely(workingset)) { > psi_memstall_enter(&pflags); > error = filler(file, folio); > psi_memstall_leave(&pflags); > } else { > error = filler(file, folio); > } > if (error) > return error; I had it both ways. For any non-trivial code in the conditionals I tend to go with your version all the time. But for two times a single lines both variants tends to suck, so I can live with either one.