On Mon, Jul 4, 2022 at 4:19 PM Al Viro <viro@xxxxxxxxxxxxxxxxxx> wrote: > > - unsigned seq, m_seq, r_seq; > + unsigned seq, next_seq, m_seq, r_seq; So the main thing I react to here is how "next_seq" is in the "struct nameidata", but then it always goes together with a "struct dentry" that you end up having to pass separately (and that is *not* in that "struct nameidata"). Now, saving the associated dentry (as "next_dentry") in the nd would solve that, but ends up benign ugly since everything then wants to look at the dentry anyway, so while it would solve the inconsistency, it would be ugly. I wonder if the solution might not be to create a new structure like struct rcu_dentry { struct dentry *dentry; unsigned seq; }; and in fact then we could make __d_lookup_rcu() return one of these things (we already rely on that "returning a two-word structure is efficient" elsewhere). That would then make that "this dentry goes with this sequence number" be a very clear thing, and I actually thjink that it would make __d_lookup_rcu() have a cleaner calling convention too, ie we'd go from dentry = __d_lookup_rcu(parent, &nd->last, &nd->next_seq); rto dseq = __d_lookup_rcu(parent, &nd->last); and it would even improve code generation because it now returns the dentry and the sequence number in registers, instead of returning one in a register and one in memory. I did *not* look at how it would change some of the other places, but I do like the notion of "keep the dentry and the sequence number that goes with it together". That "keep dentry as a local, keep the sequence number that goes with it as a field in the 'nd'" really does seem an odd thing. So I'm throwing the above out as a "maybe we could do this instead..". Not a huge deal. That oddity or not, I think the patch series is an improvement. I do have a minor gripe with this too: > + nd->seq = nd->next_seq = 0; I'm not convinced "0" is a good value. It's not supposed to match anything, but it *could* match a valid sequence number. Wouldn't it be better to pick something that is explicitly invalid and has the low bit set (ie 1 or -1). We don't seem to have a SEQ_INVAL or anything like that, but it does seem that if the intent is to make it clear it's not a real sequence number any more at that point, then 0 isn't great. But again, this is more of a stylistic detail thing than a real complaint. Linus