Hi Mike, On Wed, Jun 22, 2022 at 09:17:24AM -0500, Mike Rapoport wrote: > Hi Rebecca, > > On Wed, Jun 22, 2022 at 04:29:05AM -0500, Rebecca Mckeever wrote: > > These patches add options VERBOSE and MEMBLOCK_DEBUG to Memblock > > simulator, which can be specified when running make. These patches also > > implement the functionality for these options. > > > > VERBOSE > > Usage: > > > > $ make VERBOSE=1 > > > > Passing VERBOSE=1 will enable verbose output from Memblock simulator. For > > each test, the verbose output includes the name of the memblock function > > being tested, the name of the test, and whether the test passed or failed. > > Since all the tests in Memblock simulator run as one monolithic test, this > > output is a quick way to get a summary of test results. > > > > MEMBLOCK_DEBUG > > Usage: > > > > $ make MEMBLOCK_DEBUG=1 > > > > Passing MEMBLOCK_DEBUG=1 will enable memblock_dbg() messages. These > > are debug messages built into several functions in memblock that include > > information such as the name of the function and the size and start and > > end addresses of the memblock region. > > > > Rebecca Mckeever (4): > > memblock tests: add user-provided arguments to Makefile > > memblock tests: add verbose output to memblock tests > > memblock tests: set memblock_debug to enable memblock_dbg() messages > > memblock tests: remove completed TODO items > > > > tools/testing/memblock/Makefile | 4 + > > tools/testing/memblock/README | 10 +- > > tools/testing/memblock/TODO | 14 +- > > tools/testing/memblock/internal.h | 7 + > > .../testing/memblock/scripts/Makefile.include | 10 + > > tools/testing/memblock/tests/alloc_api.c | 241 ++++++++---- > > .../memblock/tests/alloc_helpers_api.c | 135 +++++-- > > tools/testing/memblock/tests/alloc_nid_api.c | 371 ++++++++++++------ > > tools/testing/memblock/tests/basic_api.c | 365 ++++++++++++----- > > tools/testing/memblock/tests/common.c | 58 +++ > > tools/testing/memblock/tests/common.h | 54 +++ > > 11 files changed, 913 insertions(+), 356 deletions(-) > > > > --- > > Changes > > > > v1 -> v2 > > PATCH 2, in common.c: > > Remove #ifdef VERBOSE around prefixes and related constants > > Add __maybe_unused to prefixes > > Move PREFIXES_LEN_MAX, DELIM, and DELIM_LEN so that they are > > immediately after the other constants > > Add #ifdef VERBOSE around definitions for test_*() and prefix_*() > > > > v2 -> v3 > > PATCH 1: > > Add Reviewed-by tag > > --- > > The patch changelog in a cover letter usually goes before the commit list > and diffstat. > Thanks for letting me know, I will do that next time. > > -- > > 2.34.1 > > > > -- > Sincerely yours, > Mike. Thanks, Rebecca