On Sat, May 28, 2022 at 06:50:51AM +0000, Tong Tiangen wrote: > Currently, We use _cond_extable for cache maintenance uaccess helper > caches_clean_inval_user_pou(), so this should be moved over to > EX_TYPE_UACCESS_ERR_ZERO and rename _cond_extable to _cond_uaccess_extable > for clarity. > > Suggested-by: Mark Rutland <mark.rutland@xxxxxxx> > Signed-off-by: Tong Tiangen <tongtiangen@xxxxxxxxxx> Acked-by: Mark Rutland <mark.rutland@xxxxxxx> Mark. > --- > arch/arm64/include/asm/asm-extable.h | 6 +++--- > arch/arm64/include/asm/assembler.h | 4 ++-- > 2 files changed, 5 insertions(+), 5 deletions(-) > > diff --git a/arch/arm64/include/asm/asm-extable.h b/arch/arm64/include/asm/asm-extable.h > index 9c94ac1f082c..d01bd94cc4c2 100644 > --- a/arch/arm64/include/asm/asm-extable.h > +++ b/arch/arm64/include/asm/asm-extable.h > @@ -40,9 +40,9 @@ > * Create an exception table entry for `insn` if `fixup` is provided. Otherwise > * do nothing. > */ > - .macro _cond_extable, insn, fixup > - .ifnc \fixup, > - _asm_extable \insn, \fixup > + .macro _cond_uaccess_extable, insn, fixup > + .ifnc \fixup, > + _asm_extable_uaccess \insn, \fixup > .endif > .endm > > diff --git a/arch/arm64/include/asm/assembler.h b/arch/arm64/include/asm/assembler.h > index 8c5a61aeaf8e..dc422fa437c2 100644 > --- a/arch/arm64/include/asm/assembler.h > +++ b/arch/arm64/include/asm/assembler.h > @@ -423,7 +423,7 @@ alternative_endif > b.lo .Ldcache_op\@ > dsb \domain > > - _cond_extable .Ldcache_op\@, \fixup > + _cond_uaccess_extable .Ldcache_op\@, \fixup > .endm > > /* > @@ -462,7 +462,7 @@ alternative_endif > dsb ish > isb > > - _cond_extable .Licache_op\@, \fixup > + _cond_uaccess_extable .Licache_op\@, \fixup > .endm > > /* > -- > 2.25.1 >