On 01.06.22 11:54, Muchun Song wrote: > On Wed, Jun 01, 2022 at 11:32:37AM +0200, David Hildenbrand wrote: >> On 04.04.22 09:46, Muchun Song wrote: >>> The word of "free" is not expressive enough to express the feature of optimizing >>> vmemmap pages associated with each HugeTLB, rename this keywork to "optimeze". >>> In this patch , cheanup configs to make code more expressive. >> >> Nit: why not simply CONFIG_HUGETLB_OPTIMIZE_VMEMMAP if we're touching >> this already? At least I don't see value in the additional "PAGE" :) >> > > I thought it keep consistent with CONFIG_HUGETLB_PAGE. If you think > CONFIG_HUGETLB_OPTIMIZE_VMEMMAP is a better name, maybe we need to > another separate patch since this series is already on mm-stable branch. I see, makes sense then. >>> >>> Signed-off-by: Muchun Song <songmuchun@xxxxxxxxxxxxx> >>> --- >>> Documentation/admin-guide/kernel-parameters.txt | 4 ++-- >>> Documentation/admin-guide/mm/hugetlbpage.rst | 2 +- >>> arch/arm64/Kconfig | 2 +- >>> arch/arm64/mm/flush.c | 2 +- >>> arch/x86/Kconfig | 2 +- >>> arch/x86/mm/init_64.c | 2 +- >>> fs/Kconfig | 16 ++++++++-------- >>> include/linux/hugetlb.h | 2 +- >>> include/linux/mm.h | 2 +- >>> include/linux/page-flags.h | 6 +++--- >>> mm/Makefile | 2 +- >>> mm/hugetlb_vmemmap.c | 4 ++-- >>> mm/hugetlb_vmemmap.h | 4 ++-- >>> mm/sparse-vmemmap.c | 4 ++-- >>> 14 files changed, 27 insertions(+), 27 deletions(-) >>> >>> diff --git a/Documentation/admin-guide/kernel-parameters.txt b/Documentation/admin-guide/kernel-parameters.txt >>> index 56edbe3f458f..89a58ac49d5f 100644 >>> --- a/Documentation/admin-guide/kernel-parameters.txt >>> +++ b/Documentation/admin-guide/kernel-parameters.txt >>> @@ -1660,7 +1660,7 @@ >>> Format: size[KMG] >>> >>> hugetlb_free_vmemmap= >> >> We didn't change the parameter name in #2, correct? >> > > I think this is a interface to users. Is it correct to > change it? I guess so ... I was just wanted to confirm that this is still correct :) -- Thanks, David / dhildenb