On Fri, May 20, 2022 at 06:58:12PM +0200, Christophe JAILLET wrote: > Le 09/05/2022 à 20:38, Roman Gushchin a écrit : > > This commit introduces the /sys/kernel/debug/shrinker debugfs > > interface which provides an ability to observe the state of > > individual kernel memory shrinkers. > > > > Because the feature adds some memory overhead (which shouldn't be > > large unless there is a huge amount of registered shrinkers), it's > > guarded by a config option (enabled by default). > > > > This commit introduces the "count" interface for each shrinker > > registered in the system. > > > > The output is in the following format: > > <cgroup inode id> <nr of objects on node 0> <nr of objects on node 1>... > > <cgroup inode id> <nr of objects on node 0> <nr of objects on node 1>... > > ... > > > > To reduce the size of output on machines with many thousands cgroups, > > if the total number of objects on all nodes is 0, the line is omitted. > > > > If the shrinker is not memcg-aware or CONFIG_MEMCG is off, 0 is > > printed as cgroup inode id. If the shrinker is not numa-aware, 0's are > > printed for all nodes except the first one. > > > > This commit gives debugfs entries simple numeric names, which are not > > very convenient. The following commit in the series will provide > > shrinkers with more meaningful names. > > > > Signed-off-by: Roman Gushchin <roman.gushchin@xxxxxxxxx> > > --- > > include/linux/shrinker.h | 19 ++++- > > lib/Kconfig.debug | 9 +++ > > mm/Makefile | 1 + > > mm/shrinker_debug.c | 171 +++++++++++++++++++++++++++++++++++++++ > > mm/vmscan.c | 6 +- > > 5 files changed, 203 insertions(+), 3 deletions(-) > > create mode 100644 mm/shrinker_debug.c > > > > diff --git a/include/linux/shrinker.h b/include/linux/shrinker.h > > index 76fbf92b04d9..2ced8149c513 100644 > > --- a/include/linux/shrinker.h > > +++ b/include/linux/shrinker.h > > @@ -72,6 +72,10 @@ struct shrinker { > > #ifdef CONFIG_MEMCG > > /* ID in shrinker_idr */ > > int id; > > +#endif > > +#ifdef CONFIG_SHRINKER_DEBUG > > + int debugfs_id; > > + struct dentry *debugfs_entry; > > #endif > > /* objs pending delete, per node */ > > atomic_long_t *nr_deferred; > > @@ -94,4 +98,17 @@ extern int register_shrinker(struct shrinker *shrinker); > > extern void unregister_shrinker(struct shrinker *shrinker); > > extern void free_prealloced_shrinker(struct shrinker *shrinker); > > extern void synchronize_shrinkers(void); > > -#endif > > + > > +#ifdef CONFIG_SHRINKER_DEBUG > > +extern int shrinker_debugfs_add(struct shrinker *shrinker); > > +extern void shrinker_debugfs_remove(struct shrinker *shrinker); > > +#else /* CONFIG_SHRINKER_DEBUG */ > > +static inline int shrinker_debugfs_add(struct shrinker *shrinker) > > +{ > > + return 0; > > +} > > +static inline void shrinker_debugfs_remove(struct shrinker *shrinker) > > +{ > > +} > > +#endif /* CONFIG_SHRINKER_DEBUG */ > > +#endif /* _LINUX_SHRINKER_H */ > > diff --git a/lib/Kconfig.debug b/lib/Kconfig.debug > > index 3fd7a2e9eaf1..5fa65a649798 100644 > > --- a/lib/Kconfig.debug > > +++ b/lib/Kconfig.debug > > @@ -733,6 +733,15 @@ config SLUB_STATS > > out which slabs are relevant to a particular load. > > Try running: slabinfo -DA > > +config SHRINKER_DEBUG > > + default y > > The previous version of the serie had default 'n'. > Is it intentional to have it now activated by default? It looked more like a > tuning functionality when fine grained mangement of shrinker is needed. Yes, it is intentional. The overhead is small, so I don't think we have a good reason to hide it by default behind a config option. In my opinion, enabling it be default will increase the chances to gather a useful data. It was the feedback I've received for one of the previous versions of the patchset, and I think it's totally valid. And preserving the config option allows to have a zero overhead for really constrained systems. Thanks!