On Mon, May 9, 2022 at 11:24 AM Miaohe Lin <linmiaohe@xxxxxxxxxx> wrote: > > On 2022/4/29 19:36, Muchun Song wrote: > > On Mon, Apr 25, 2022 at 09:27:22PM +0800, Miaohe Lin wrote: > >> We might fail to isolate huge page due to e.g. the page is under migration > >> which cleared HPageMigratable. So we should return -EBUSY in this case > >> rather than always return 1 which could confuse the user. Also we make > >> the prototype of isolate_huge_page consistent with isolate_lru_page to > >> improve the readability. > >> > >> Fixes: e8db67eb0ded ("mm: migrate: move_pages() supports thp migration") > >> Suggested-by: Huang Ying <ying.huang@xxxxxxxxx> > >> Signed-off-by: Miaohe Lin <linmiaohe@xxxxxxxxxx> > >> --- > >> include/linux/hugetlb.h | 6 +++--- > >> mm/gup.c | 2 +- > >> mm/hugetlb.c | 11 +++++------ > >> mm/memory-failure.c | 2 +- > >> mm/mempolicy.c | 2 +- > >> mm/migrate.c | 5 +++-- > >> 6 files changed, 14 insertions(+), 14 deletions(-) > >> > >> diff --git a/include/linux/hugetlb.h b/include/linux/hugetlb.h > >> index 04f0186b089b..306d6ef3fa22 100644 > >> --- a/include/linux/hugetlb.h > >> +++ b/include/linux/hugetlb.h > >> @@ -170,7 +170,7 @@ bool hugetlb_reserve_pages(struct inode *inode, long from, long to, > >> vm_flags_t vm_flags); > >> long hugetlb_unreserve_pages(struct inode *inode, long start, long end, > >> long freed); > >> -bool isolate_huge_page(struct page *page, struct list_head *list); > >> +int isolate_huge_page(struct page *page, struct list_head *list); > >> int get_hwpoison_huge_page(struct page *page, bool *hugetlb); > >> int get_huge_page_for_hwpoison(unsigned long pfn, int flags); > >> void putback_active_hugepage(struct page *page); > >> @@ -376,9 +376,9 @@ static inline pte_t *huge_pte_offset(struct mm_struct *mm, unsigned long addr, > >> return NULL; > >> } > >> > >> -static inline bool isolate_huge_page(struct page *page, struct list_head *list) > >> +static inline int isolate_huge_page(struct page *page, struct list_head *list) > > > > Since you already touched all the call sites, how about renaming this > > to hugetlb_isolate()? I've always felt that huge_page is not a > > straightforward and clear name since we also have another type of > > huge page (THP). I think hugetlb is more specific. > > > > Sorry for late respond. This suggestion looks good to me. But is isolate_hugetlb more suitable? > This could make it more consistent with isolate_lru_page? What do you think? > There is also a function named folio_isolate_lru(). My initial consideration was making it consistent with folio_isolate_lru(). isolate_hugetlb looks good to me as well. Thanks.