[PATCH] mm/vmscan: reorder scan_balance definition to simplify the scan type check

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Even is_file_lru() return bool type, we leverage it as an index for anon
or file.

With this in hand, after reorder scan_balance definition, we can compare
directly between scan_balance and file to get the exclusive scan type.

After this, the code looks more readable and save some instructions.

Signed-off-by: Wei Yang <richard.weiyang@xxxxxxxxx>
CC: Johannes Weiner <hannes@xxxxxxxxxxx>
CC: Mel Gorman <mgorman@xxxxxxx>
---
 mm/vmscan.c | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/mm/vmscan.c b/mm/vmscan.c
index 89745cf34386..0b7cc9309e70 100644
--- a/mm/vmscan.c
+++ b/mm/vmscan.c
@@ -2638,10 +2638,10 @@ static bool inactive_is_low(struct lruvec *lruvec, enum lru_list inactive_lru)
 }
 
 enum scan_balance {
-	SCAN_EQUAL,
-	SCAN_FRACT,
 	SCAN_ANON,
 	SCAN_FILE,
+	SCAN_EQUAL,
+	SCAN_FRACT,
 };
 
 /*
@@ -2838,7 +2838,7 @@ static void get_scan_count(struct lruvec *lruvec, struct scan_control *sc,
 		case SCAN_FILE:
 		case SCAN_ANON:
 			/* Scan one type exclusively */
-			if ((scan_balance == SCAN_FILE) != file)
+			if (scan_balance != file)
 				scan = 0;
 			break;
 		default:
-- 
2.33.1





[Index of Archives]     [Linux ARM Kernel]     [Linux ARM]     [Linux Omap]     [Fedora ARM]     [IETF Annouce]     [Bugtraq]     [Linux OMAP]     [Linux MIPS]     [eCos]     [Asterisk Internet PBX]     [Linux API]

  Powered by Linux