On 2022/3/30 16:13, Muchun Song wrote: > On Tue, Mar 29, 2022 at 9:26 PM Miaohe Lin <linmiaohe@xxxxxxxxxx> wrote: >> >> When folio is file lru, folio_test_swapbacked is guaranteed to be true. So >> it's unnecessary to check it here again. No functional change intended. >> >> Signed-off-by: Miaohe Lin <linmiaohe@xxxxxxxxxx> >> --- >> mm/vmscan.c | 3 +-- >> 1 file changed, 1 insertion(+), 2 deletions(-) >> >> diff --git a/mm/vmscan.c b/mm/vmscan.c >> index 1678802e03e7..7c1a9713bfc9 100644 >> --- a/mm/vmscan.c >> +++ b/mm/vmscan.c >> @@ -1434,8 +1434,7 @@ static void folio_check_dirty_writeback(struct folio *folio, >> * Anonymous pages are not handled by flushers and must be written >> * from reclaim context. Do not stall reclaim based on them >> */ >> - if (!folio_is_file_lru(folio) || >> - (folio_test_anon(folio) && !folio_test_swapbacked(folio))) { >> + if (!folio_is_file_lru(folio) || folio_test_anon(folio)) { > > At least your login is no problem since folio_is_file_lru() is equal to > !folio_test_swapbacked(). But the new code is not clear to me. > The old code is easy to understand, e.g. folio_test_anon(folio) && > !folio_test_swapbacked(folio) tells us that the anon pages which > do not need to be swapped should be skipped. So I'm neutral on > the patch. Thanks for your comment. The previous one might look more common: folio_test_anon(folio) && !folio_test_swapbacked(folio) means folio is MADV_FREE and can be freed without swapping out. And I remove the unneeded !folio_test_swapbacked(folio) check at the expense of losing minor readability. If it is not worth doing this, I will drop this patch. Thanks. > > . >