Hi everyone, This series contains a few patches to remove unneeded variables, jump label and use helper to simplify the code. Also we fix some bugs such as page refcounts leak , invalid node access and so on. More details can be found in the respective changelogs. Thanks! --- v1->v2: collect reviewed-by tag fix some commit log remove unneeded nr_failed assignment per Huang Ying getting the types correct to use min() per Andrew delay some patches to make this easier to move forward Thanks Muchun, Baolin, Zi Yan,Huang Ying, Andrew, Alistair for review! --- Miaohe Lin (11): mm/migration: remove unneeded local variable mapping_locked mm/migration: remove unneeded out label mm/migration: remove unneeded local variable page_lru mm/migration: fix the confusing PageTransHuge check mm/migration: use helper function vma_lookup() in add_page_for_migration mm/migration: use helper macro min in do_pages_stat mm/migration: avoid unneeded nodemask_t initialization mm/migration: remove some duplicated codes in migrate_pages mm/migration: fix potential page refcounts leak in migrate_pages mm/migration: fix potential invalid node access for reclaim-based migration mm/migration: fix possible do_pages_stat_array racing with memory offline mm/migrate.c | 94 +++++++++++++++++++++++----------------------------- 1 file changed, 42 insertions(+), 52 deletions(-) -- 2.23.0