On Tue, Mar 08, 2022 at 10:41:38AM -0500, Waiman Long wrote: > On 3/7/22 23:39, Roman Gushchin wrote: > > On Mon, Mar 07, 2022 at 10:30:09PM -0500, Waiman Long wrote: > > > Since commit 2c80cd57c743 ("mm/list_lru.c: fix list_lru_count_node() > > > to be race free"), we are tracking the total number of lru > > > entries in a list_lru_node in its nr_items field. In the case of > > > memcg_drain_list_lru_node(), there is nothing to be done if nr_items > > > is 0. We don't even need to take the nlru->lock as no new lru entry > > > could be added by a racing list_lru_add() to the draining src_idx memcg > > > at this point. > > > > > > Signed-off-by: Waiman Long <longman@xxxxxxxxxx> > > Hi Waiman! > > > > The patch makes total sense to me, however it needs to be rebased at least > > on top of "mm: list_lru: rename memcg_drain_all_list_lrus to memcg_reparent_list_lrus". > > > > Thanks! > > > > > This patch was based on the current linux-next tree which includes commit > ff221bc26bdd ("mm: list_lru: rename memcg_drain_all_list_lrus to > memcg_reparent_list_lrus"). I do remember to double-check linux-next before > sending this patch out. In fact, the same patch can be applied to both linux > and linux-next tree without problem. I'm looking at the mm tree (https://github.com/hnaz/linux-mm.git) and clearly see that commit "mm: list_lru: rename memcg_drain_all_list_lrus to memcg_reparent_list_lrus" eliminated the function with the name memcg_drain_list_lru_node(), which your patch is touching. Currently the function is located in list_lru.c and is named memcg_reparent_list_lru_node(). linux-next is sometimes a bit behind the mm tree. Thanks!