On 2022/3/7 10:03, Huang, Ying wrote: > Miaohe Lin <linmiaohe@xxxxxxxxxx> writes: > >> We can do prep_transhuge_page when newpage is not NULL. Thus we can remove >> out label to simplify the code. >> >> Signed-off-by: Miaohe Lin <linmiaohe@xxxxxxxxxx> >> --- >> mm/migrate.c | 7 ++----- >> 1 file changed, 2 insertions(+), 5 deletions(-) >> >> diff --git a/mm/migrate.c b/mm/migrate.c >> index 50bc62d85eaf..bc1867a5706c 100644 >> --- a/mm/migrate.c >> +++ b/mm/migrate.c >> @@ -2025,12 +2025,9 @@ static struct page *alloc_misplaced_dst_page_thp(struct page *page, >> >> newpage = alloc_pages_node(nid, (GFP_TRANSHUGE_LIGHT | __GFP_THISNODE), >> HPAGE_PMD_ORDER); >> - if (!newpage) >> - goto out; >> + if (newpage) >> + prep_transhuge_page(newpage); >> >> - prep_transhuge_page(newpage); >> - >> -out: >> return newpage; >> } > > I don't think this change is necessary. The original code is simple and > follows the common practice for error processing. The new code is OK, > but it's unnecessary to change. > IMO, this out label looks 'overkill'. We should remove it and make code more succinct. Does this make sense to you? Thanks. > Best Regards, > Huang, Ying > . >