On 2/15/22 17:07, Kees Cook wrote: > On Tue, Feb 15, 2022 at 01:40:55PM +0100, Christophe Leroy wrote: >> PPC64/IA64/PARISC have function descriptors. LKDTM doesn't work >> on those three architectures because LKDTM messes up function >> descriptors with functions. >> >> This series does some cleanup in the three architectures and >> refactors function descriptors so that it can then easily use it >> in a generic way in LKDTM. > > Thanks for doing this! It looks good to me. :) I endorse that. Thank you, Christophe! Acked-by: Helge Deller <deller@xxxxxx> Helge > -Kees > >> >> Changes in v4: >> - Added patch 1 which Fixes 'sparse' for powerpc64le after wrong report on previous series, refer https://github.com/ruscur/linux-ci/actions/runs/1351427671 >> - Exported dereference_function_descriptor() to modules >> - Addressed other received comments >> - Rebased on latest powerpc/next (5a72345e6a78120368fcc841b570331b6c5a50da) >> >> Changes in v3: >> - Addressed received comments >> - Swapped some of the powerpc patches to keep func_descr_t renamed as struct func_desc and remove 'struct ppc64_opd_entry' >> - Changed HAVE_FUNCTION_DESCRIPTORS macro to a config item CONFIG_HAVE_FUNCTION_DESCRIPTORS >> - Dropped patch 11 ("Fix lkdtm_EXEC_RODATA()") >> >> Changes in v2: >> - Addressed received comments >> - Moved dereference_[kernel]_function_descriptor() out of line >> - Added patches to remove func_descr_t and func_desc_t in powerpc >> - Using func_desc_t instead of funct_descr_t >> - Renamed HAVE_DEREFERENCE_FUNCTION_DESCRIPTOR to HAVE_FUNCTION_DESCRIPTORS >> - Added a new lkdtm test to check protection of function descriptors >> >> Christophe Leroy (13): >> powerpc: Fix 'sparse' checking on PPC64le >> powerpc: Move and rename func_descr_t >> powerpc: Use 'struct func_desc' instead of 'struct ppc64_opd_entry' >> powerpc: Remove 'struct ppc64_opd_entry' >> powerpc: Prepare func_desc_t for refactorisation >> ia64: Rename 'ip' to 'addr' in 'struct fdesc' >> asm-generic: Define CONFIG_HAVE_FUNCTION_DESCRIPTORS >> asm-generic: Define 'func_desc_t' to commonly describe function >> descriptors >> asm-generic: Refactor dereference_[kernel]_function_descriptor() >> lkdtm: Force do_nothing() out of line >> lkdtm: Really write into kernel text in WRITE_KERN >> lkdtm: Fix execute_[user]_location() >> lkdtm: Add a test for function descriptors protection >> >> arch/Kconfig | 3 + >> arch/ia64/Kconfig | 1 + >> arch/ia64/include/asm/elf.h | 2 +- >> arch/ia64/include/asm/sections.h | 24 +------- >> arch/ia64/kernel/module.c | 6 +- >> arch/parisc/Kconfig | 1 + >> arch/parisc/include/asm/sections.h | 16 ++---- >> arch/parisc/kernel/process.c | 21 ------- >> arch/powerpc/Kconfig | 1 + >> arch/powerpc/Makefile | 2 +- >> arch/powerpc/include/asm/code-patching.h | 2 +- >> arch/powerpc/include/asm/elf.h | 6 ++ >> arch/powerpc/include/asm/sections.h | 29 ++-------- >> arch/powerpc/include/asm/types.h | 6 -- >> arch/powerpc/include/uapi/asm/elf.h | 8 --- >> arch/powerpc/kernel/module_64.c | 42 ++++++-------- >> arch/powerpc/kernel/ptrace/ptrace.c | 6 ++ >> arch/powerpc/kernel/signal_64.c | 8 +-- >> drivers/misc/lkdtm/core.c | 1 + >> drivers/misc/lkdtm/lkdtm.h | 1 + >> drivers/misc/lkdtm/perms.c | 71 +++++++++++++++++++----- >> include/asm-generic/sections.h | 15 ++++- >> include/linux/kallsyms.h | 2 +- >> kernel/extable.c | 24 +++++++- >> tools/testing/selftests/lkdtm/tests.txt | 1 + >> 25 files changed, 155 insertions(+), 144 deletions(-) >> >> -- >> 2.34.1 >> >