On Wed, Dec 22, 2021 at 8:01 AM Marco Elver <elver@xxxxxxxxxx> wrote: > > On Mon, 20 Dec 2021 at 22:58, <andrey.konovalov@xxxxxxxxx> wrote: > > > > From: Andrey Konovalov <andreyknvl@xxxxxxxxxx> > > > > Hi, > > > > This patchset adds vmalloc tagging support for SW_TAGS and HW_TAGS > > KASAN modes. > > > > The tree with patches is available here: > > > > https://github.com/xairy/linux/tree/up-kasan-vmalloc-tags-v4-akpm > > > > About half of patches are cleanups I went for along the way. None of > > them seem to be important enough to go through stable, so I decided > > not to split them out into separate patches/series. > > > > The patchset is partially based on an early version of the HW_TAGS > > patchset by Vincenzo that had vmalloc support. Thus, I added a > > Co-developed-by tag into a few patches. > > > > SW_TAGS vmalloc tagging support is straightforward. It reuses all of > > the generic KASAN machinery, but uses shadow memory to store tags > > instead of magic values. Naturally, vmalloc tagging requires adding > > a few kasan_reset_tag() annotations to the vmalloc code. > > > > HW_TAGS vmalloc tagging support stands out. HW_TAGS KASAN is based on > > Arm MTE, which can only assigns tags to physical memory. As a result, > > HW_TAGS KASAN only tags vmalloc() allocations, which are backed by > > page_alloc memory. It ignores vmap() and others. > > > > Changes in v3->v4: > [...] > > Andrey Konovalov (39): > > kasan, page_alloc: deduplicate should_skip_kasan_poison > > kasan, page_alloc: move tag_clear_highpage out of > > kernel_init_free_pages > > kasan, page_alloc: merge kasan_free_pages into free_pages_prepare > > kasan, page_alloc: simplify kasan_poison_pages call site > > kasan, page_alloc: init memory of skipped pages on free > > kasan: drop skip_kasan_poison variable in free_pages_prepare > > mm: clarify __GFP_ZEROTAGS comment > > kasan: only apply __GFP_ZEROTAGS when memory is zeroed > > kasan, page_alloc: refactor init checks in post_alloc_hook > > kasan, page_alloc: merge kasan_alloc_pages into post_alloc_hook > > kasan, page_alloc: combine tag_clear_highpage calls in post_alloc_hook > > kasan, page_alloc: move SetPageSkipKASanPoison in post_alloc_hook > > kasan, page_alloc: move kernel_init_free_pages in post_alloc_hook > > kasan, page_alloc: rework kasan_unpoison_pages call site > > kasan: clean up metadata byte definitions > > kasan: define KASAN_VMALLOC_INVALID for SW_TAGS > > kasan, x86, arm64, s390: rename functions for modules shadow > > kasan, vmalloc: drop outdated VM_KASAN comment > > kasan: reorder vmalloc hooks > > kasan: add wrappers for vmalloc hooks > > kasan, vmalloc: reset tags in vmalloc functions > > kasan, fork: reset pointer tags of vmapped stacks > > kasan, arm64: reset pointer tags of vmapped stacks > > kasan, vmalloc: add vmalloc tagging for SW_TAGS > > kasan, vmalloc, arm64: mark vmalloc mappings as pgprot_tagged > > kasan, vmalloc: unpoison VM_ALLOC pages after mapping > > kasan, mm: only define ___GFP_SKIP_KASAN_POISON with HW_TAGS > > kasan, page_alloc: allow skipping unpoisoning for HW_TAGS > > kasan, page_alloc: allow skipping memory init for HW_TAGS > > kasan, vmalloc: add vmalloc tagging for HW_TAGS > > kasan, vmalloc: only tag normal vmalloc allocations > > kasan, arm64: don't tag executable vmalloc allocations > > kasan: mark kasan_arg_stacktrace as __initdata > > kasan: simplify kasan_init_hw_tags > > kasan: add kasan.vmalloc command line flag > > kasan: allow enabling KASAN_VMALLOC and SW/HW_TAGS > > arm64: select KASAN_VMALLOC for SW/HW_TAGS modes > > kasan: documentation updates > > kasan: improve vmalloc tests > > Functionally it all looks good. So rather than acking every patch, for > the whole series: > > Acked-by: Marco Elver <elver@xxxxxxxxxx> > > ... and in case you do a v5, I've left some minor comments. I will, thanks! > Happy holidays! Happy holidays to you too!