From: Andrey Konovalov <andreyknvl@xxxxxxxxxx> Pull the kernel_init_free_pages() call in post_alloc_hook() out of the big if clause for better code readability. This also allows for more simplifications in the following patch. This patch does no functional changes. Signed-off-by: Andrey Konovalov <andreyknvl@xxxxxxxxxx> --- mm/page_alloc.c | 12 ++++++++---- 1 file changed, 8 insertions(+), 4 deletions(-) diff --git a/mm/page_alloc.c b/mm/page_alloc.c index c78befc4e057..ba950889f5ea 100644 --- a/mm/page_alloc.c +++ b/mm/page_alloc.c @@ -2421,14 +2421,18 @@ inline void post_alloc_hook(struct page *page, unsigned int order, init = false; } if (kasan_has_integrated_init()) { - if (!init_tags) + if (!init_tags) { kasan_unpoison_pages(page, order, init); + + /* Note that memory is already initialized by KASAN. */ + init = false; + } } else { kasan_unpoison_pages(page, order, init); - - if (init) - kernel_init_free_pages(page, 1 << order); } + /* If memory is still not initialized, do it now. */ + if (init) + kernel_init_free_pages(page, 1 << order); /* Propagate __GFP_SKIP_KASAN_POISON to page flags. */ if (IS_ENABLED(CONFIG_KASAN_HW_TAGS) && (gfp_flags & __GFP_SKIP_KASAN_POISON)) -- 2.25.1