On Mon, 11 Oct 2021 at 19:02, Vlastimil Babka <vbabka@xxxxxxx> wrote: [...] > > On the other hand, the lazy initialization mode you're introducing > > requires an explicit stack_depot_init() call somewhere and isn't as > > straightforward as before. > > > > Not sure what is best. My intuition tells me STACKDEPOT_LAZY_INIT would > > be safer as it's a deliberate opt-in to the lazy initialization > > behaviour. > > I think it should be fine with ALWAYS_INIT. There are not many stackdepot > users being added, and anyone developing a new one will very quickly find > out if they forget to call stack_depot_init()? I think that's fine. > > Preferences? > > > > [...] > >> --- a/drivers/gpu/drm/drm_mm.c > >> +++ b/drivers/gpu/drm/drm_mm.c > >> @@ -980,6 +980,10 @@ void drm_mm_init(struct drm_mm *mm, u64 start, u64 size) > >> add_hole(&mm->head_node); > >> > >> mm->scan_active = 0; > >> + > >> +#ifdef CONFIG_DRM_DEBUG_MM > >> + stack_depot_init(); > >> +#endif > > > > DRM_DEBUG_MM implies STACKDEPOT. Not sure what is more readable to drm > > maintainers, but perhaps it'd be nicer to avoid the #ifdef here, and > > instead just keep the no-op version of stack_depot_init() in > > <linux/stackdepot.h>. I don't have a strong preference. > > Hm, but in case STACKDEPOT is also selected by something else (e.g. > CONFIG_PAGE_OWNER) which uses lazy init but isn't enabled on boot, then > without #ifdef CONFIG_DRM_DEBUG_MM above, this code would call a > stack_depot_init() (that's not a no-op) even in case it's not going to be > using it, so not what we want to achieve. > But it could be changed to use IS_ENABLED() if that's preferred by DRM folks. You're right -- but I'll leave this to DRM folks. > BTW it's possible that there won't be any DRM review because this failed to > apply: > https://patchwork.freedesktop.org/series/95549/ > DRM folks, any hint how to indicate that the base was next-20211001? > [...] > > +#ifdef CONFIG_STACKDEPOT_ALWAYS_INIT > > +static inline int stack_depot_early_init(void) { return stack_depot_init(); } > > +#else > > +static inline int stack_depot_early_init(void) { return 0; } > > +#endif /* CONFIG_STACKDEPOT_ALWAYS_INIT */ > > We could, but it's a wrapper made for only a single caller... > > >> #endif > >> diff --git a/init/main.c b/init/main.c > >> index ee4d3e1b3eb9..b6a5833d98f5 100644 > >> --- a/init/main.c > >> +++ b/init/main.c > >> @@ -844,7 +844,8 @@ static void __init mm_init(void) > >> init_mem_debugging_and_hardening(); > >> kfence_alloc_pool(); > >> report_meminit(); > >> - stack_depot_init(); > >> + if (IS_ENABLED(CONFIG_STACKDEPOT_ALWAYS_INIT)) > >> + stack_depot_init(); > > > > I'd push the decision of when to call this into <linux/stackdepot.h> via > > wrapper stack_depot_early_init(). > > No strong preferrences, if you think it's worth it. All the other *init() functions seem to follow the same idiom as there are barely any IS_ENABLED() in init/main.c. So I think it's just about being consistent with the rest. Thanks, -- Marco