On Thu, Nov 24, 2011 at 11:26:06AM +0100, Michal Hocko wrote: > On Thu 24-11-11 11:05:49, Johannes Weiner wrote: > > On Thu, Nov 24, 2011 at 10:52:51AM +0100, Michal Hocko wrote: > > > On Wed 23-11-11 16:42:27, Johannes Weiner wrote: > > > > From: Johannes Weiner <jweiner@xxxxxxxxxx> > > > > > > > > Pages have their corresponding page_cgroup descriptors set up before > > > > they are used in userspace, and thus managed by a memory cgroup. > > > > > > > > The only time where lookup_page_cgroup() can return NULL is in the > > > > page sanity checking code that executes while feeding pages into the > > > > page allocator for the first time. > > > > > > > > Remove the NULL checks against lookup_page_cgroup() results from all > > > > callsites where we know that corresponding page_cgroup descriptors > > > > must be allocated. > > > > > > OK, shouldn't we add > > > > > > diff --git a/mm/page_cgroup.c b/mm/page_cgroup.c > > > index 2d123f9..cb93f64 100644 > > > --- a/mm/page_cgroup.c > > > +++ b/mm/page_cgroup.c > > > @@ -35,8 +35,7 @@ struct page_cgroup *lookup_page_cgroup(struct page *page) > > > struct page_cgroup *base; > > > > > > base = NODE_DATA(page_to_nid(page))->node_page_cgroup; > > > - if (unlikely(!base)) > > > - return NULL; > > > + BUG_ON(!base); > > > > > > offset = pfn - NODE_DATA(page_to_nid(page))->node_start_pfn; > > > return base + offset; > > > @@ -112,8 +111,7 @@ struct page_cgroup *lookup_page_cgroup(struct page *page) > > > unsigned long pfn = page_to_pfn(page); > > > struct mem_section *section = __pfn_to_section(pfn); > > > > > > - if (!section->page_cgroup) > > > - return NULL; > > > + BUG_ON(!section->page_cgroup); > > > return section->page_cgroup + pfn; > > > } > > > > > > just to make it explicit? > > > > No, see the last hunk in this patch. It's actually possible for this > > to run, although only while feeding fresh pages into the allocator: > > Bahh. Yes, I have noticed the hunk but then I started thinking about > how to make the NULL case explicit and totally forgot about that. > Sorry about the noise. > > > > > > > @@ -3326,6 +3321,7 @@ static struct page_cgroup *lookup_page_cgroup_used(struct page *page) > > > > struct page_cgroup *pc; > > > > > > > > pc = lookup_page_cgroup(page); > > > > + /* Can be NULL while bootstrapping the page allocator */ > > > > if (likely(pc) && PageCgroupUsed(pc)) > > > > return pc; > > > > return NULL; > > > > We could add a lookup_page_cgroup_safe() for this DEBUG_VM-only > > callsite as an optimization separately and remove the NULL check from > > lookup_page_cgroup() itself. But this patch was purely about removing > > the actively misleading checks. > > Yes, but I am not sure whether code duplication is worth it. Let's just > stick with current form. Maybe just move the comment when it can be NULL > to the lookup_page_cgroup directly? Don't underestimate it, this function is used quite heavily while the case of the array being NULL is a minor fraction of all calls. But it's for another patch, anyway. The case for when lookup_page_cgroup() returns NULL is kinda obvious to me when directly looking at the function itself, because the arrays are allocated just a few lines below. But care to send a patch? -- To unsubscribe, send a message with 'unsubscribe linux-mm' in the body to majordomo@xxxxxxxxx. For more info on Linux MM, see: http://www.linux-mm.org/ . Fight unfair telecom internet charges in Canada: sign http://stopthemeter.ca/ Don't email: <a href=mailto:"dont@xxxxxxxxx"> email@xxxxxxxxx </a>