On Wed, Aug 11, 2021 at 02:18:26PM -0700, Edgecombe, Rick P wrote: > On Tue, 2021-08-03 at 21:32 -0700, ira.weiny@xxxxxxxxx wrote: > > +static const pks_key_callback > > pks_key_callbacks[PKS_KEY_NR_CONSUMERS] = { 0 }; > > + > > +bool handle_pks_key_callback(unsigned long address, bool write, u16 > > key) > > +{ > > + if (key > PKS_KEY_NR_CONSUMERS) > > + return false; > Good idea, should be >= though? Yep. Fixed thanks. > > > + > > + if (pks_key_callbacks[key]) > > + return pks_key_callbacks[key](address, write); > > + > > + return false; > > +} > > + > > Otherwise, I've rebased on this series and didn't hit any problems. > Thanks. Awesome! I still want Dave and Dan to weigh in prior to me respining with the changes so far. Thanks, Ira