On Sat, Jul 31, 2021 at 12:39:38AM -0600, Yu Zhao wrote: > +++ b/include/linux/rmap.h > @@ -243,7 +243,7 @@ int page_mkclean(struct page *); > */ > void page_mlock(struct page *page); > > -void remove_migration_ptes(struct page *old, struct page *new, bool locked); > +void remove_migration_ptes(struct page *old, struct page *new, bool locked, bool unmap_clean); I'm not a big fan of 'bool, bool'. Could we use a flag word instead? #define MIGRATE_REMOVE_LOCKED 1 #define MIGRATE_UNMAP_CLEAN 2