On Wed 28-07-21 07:10:26, Shakeel Butt wrote: > +Roman > > On Wed, Jul 28, 2021 at 6:23 AM Michal Hocko <mhocko@xxxxxxxx> wrote: > > > > On Wed 28-07-21 17:13:48, Wang Hai wrote: > > > When I use kfree_rcu() to free a large memory allocated by > > > kmalloc_node(), the following dump occurs. > > > > > > BUG: kernel NULL pointer dereference, address: 0000000000000020 > > > [...] > > > Oops: 0000 [#1] SMP > > > [...] > > > Workqueue: events kfree_rcu_work > > > RIP: 0010:__obj_to_index include/linux/slub_def.h:182 [inline] > > > RIP: 0010:obj_to_index include/linux/slub_def.h:191 [inline] > > > RIP: 0010:memcg_slab_free_hook+0x120/0x260 mm/slab.h:363 > > > [...] > > > Call Trace: > > > kmem_cache_free_bulk+0x58/0x630 mm/slub.c:3293 > > > kfree_bulk include/linux/slab.h:413 [inline] > > > kfree_rcu_work+0x1ab/0x200 kernel/rcu/tree.c:3300 > > > process_one_work+0x207/0x530 kernel/workqueue.c:2276 > > > worker_thread+0x320/0x610 kernel/workqueue.c:2422 > > > kthread+0x13d/0x160 kernel/kthread.c:313 > > > ret_from_fork+0x1f/0x30 arch/x86/entry/entry_64.S:294 > > > > > > When kmalloc_node() a large memory, page is allocated, not slab, > > > so when freeing memory via kfree_rcu(), this large memory should not > > > be used by memcg_slab_free_hook(), because memcg_slab_free_hook() is > > > is used for slab. > > > > > > So in this case, there is no need to do anything with this large > > > page in memcg_slab_free_hook(), just skip it. > > > > > > Fixes: 270c6a71460e ("mm: memcontrol/slab: Use helpers to access slab page's memcg_data") > > > > Are you sure that this commit is really breaking the code. Unless I have > > missed something there shouldn't be any real change wrt. large > > allocations here. page_has_obj_cgroups is just a different name for what > > what page_objcgs is giving us. > > Actually they are different. For MEMCG_DATA_KMEM page, > page_has_obj_cgroups() will return false while page_objcgs() on > non-VM_DEBUG kernels will return "struct obj_cgroup *" instead of > "struct obj_cgroup **". Right. Thanks for the clarification. I have missed that subtle difference. -- Michal Hocko SUSE Labs