RE: [PATCH 1/5] mm: correct SECTION_SHIFT name in code comments

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



> From: Yu Zhao <yuzhao@xxxxxxxxxx>
> Sent: Tuesday, May 18, 2021 1:18 AM
> 
> On Mon, May 17, 2021 at 5:21 AM Dong Aisheng <aisheng.dong@xxxxxxx>
> wrote:
> >
> > Actually SECTIONS_SHIFT is used in the kernel code, fixed the code
> > comments. BTW, also moved the code comment to where it's defined.
> >
> > Also fixed a checkpatch complain derived from the original code:
> > WARNING: please, no space before tabs
> > + * SECTIONS_SHIFT    ^I^I#bits space required to store a section #$
> >
> > Cc: Andrew Morton <akpm@xxxxxxxxxxxxxxxxxxxx>
> > Cc: Yu Zhao <yuzhao@xxxxxxxxxx>
> > Cc: Andrey Konovalov <andreyknvl@xxxxxxxxx>
> > Cc: Catalin Marinas <catalin.marinas@xxxxxxx>
> > Cc: Kees Cook <keescook@xxxxxxxxxxxx>
> > Signed-off-by: Dong Aisheng <aisheng.dong@xxxxxxx>
> > ---
> >  include/linux/mmzone.h            | 2 --
> >  include/linux/page-flags-layout.h | 3 +++
> >  2 files changed, 3 insertions(+), 2 deletions(-)
> >
> > diff --git a/include/linux/mmzone.h b/include/linux/mmzone.h index
> > 9cdc88d09f2b..fc23e36cb165 100644
> > --- a/include/linux/mmzone.h
> > +++ b/include/linux/mmzone.h
> > @@ -1198,8 +1198,6 @@ static inline struct zoneref
> > *first_zones_zonelist(struct zonelist *zonelist,  #ifdef
> > CONFIG_SPARSEMEM
> >
> >  /*
> > - * SECTION_SHIFT               #bits space required to store a section #
> > - *
> >   * PA_SECTION_SHIFT            physical address to/from section
> number
> >   * PFN_SECTION_SHIFT           pfn to/from section number
> >   */
> > diff --git a/include/linux/page-flags-layout.h
> > b/include/linux/page-flags-layout.h
> > index ef1e3e736e14..aff616855492 100644
> > --- a/include/linux/page-flags-layout.h
> > +++ b/include/linux/page-flags-layout.h
> > @@ -26,6 +26,9 @@
> >
> >  #define ZONES_WIDTH            ZONES_SHIFT
> >
> > +/*
> > + * SECTIONS_SHIFT              #bits space required to store a section #
> > + */
> 
> IMO, we should either make the original comment helpful or just remove it.
> Moving it here doesn't improve readability because it's stating the obvious.
> 

Sounds good to me.
If not objections, I will remove it in v2 later.
Thanks for the suggestion.

Regards
Aisheng

> >  #ifdef CONFIG_SPARSEMEM
> >  #include <asm/sparsemem.h>
> >  #define SECTIONS_SHIFT (MAX_PHYSMEM_BITS - SECTION_SIZE_BITS)
> > --
> > 2.25.1
> >




[Index of Archives]     [Linux ARM Kernel]     [Linux ARM]     [Linux Omap]     [Fedora ARM]     [IETF Annouce]     [Bugtraq]     [Linux OMAP]     [Linux MIPS]     [eCos]     [Asterisk Internet PBX]     [Linux API]

  Powered by Linux