Hi Brian, Hugh, On 3/16/21 7:18 PM, Brian Geffon wrote: > Hi Hugh, > Thanks for this suggestion, responses in line. > >> A better patch would say: >> >> - if (flags & MREMAP_DONTUNMAP && (!vma_is_anonymous(vma) || >> - vma->vm_flags & VM_SHARED)) >> + if ((flags & MREMAP_DONTUNMAP) && >> + (vma->vm_flags & (VM_DONTEXPAND | VM_PFNMAP))) >> return ERR_PTR(-EINVAL); >> >> VM_DONTEXPAND is what has long been used on special mappings, to prevent >> surprises from mremap changing the size of the mapping: MREMAP_DONTUNMAP >> introduced a different way of expanding the mapping, so VM_DONTEXPAND >> still seems a reasonable name (I've thrown in VM_PFNMAP there because >> it's in the VM_DONTEXPAND test lower down: for safety I guess, and best >> if both behave the same - though one says -EINVAL and the other -EFAULT). > > I like this idea and am happy to mail a new patch. I think it may make > sense to bring the lower block up here so that it becomes more clear > that it's not duplicate code and that the MREMAP_DONTUNMAP case > returns -EINVAL and other cases return -EFAULT. I wonder if the > -EFAULT error code would have made more sense from the start for both > cases, do you have any thoughts on changing the error code at this > point? > >> With that VM_DONTEXPAND check in, Dmitry's commit cd544fd1dc92 >> ("mremap: don't allow MREMAP_DONTUNMAP on special_mappings and aio") >> can still be reverted (as you agreed on 28th December), even though >> vma_is_anonymous() will no longer protect it. > > I agree and if Dmitry does not have time I would be happy to mail a > revert to cd544fd1dc92 as we discussed in [1]. Dmitry, would you like > me to do that? Ack. I was planning to send a patches set that includes the revert, but that's stalled a bit. As the patch just adds excessive checks, but doesn't introduce an issue, I haven't sent it separately. Feel free to revert it :-) Thanks, Dmitry