Hi all, This series contains cleanups to rework some function logics to make it more readable, use helper function and so on. More details can be found in the respective changelogs. Thanks! Miaohe Lin (6): mm/huge_memory.c: rework the function vma_adjust_trans_huge() mm/huge_memory.c: make get_huge_zero_page() return bool mm/huge_memory.c: rework the function do_huge_pmd_numa_page() slightly mm/huge_memory.c: remove redundant PageCompound() check mm/huge_memory.c: remove unused macro TRANSPARENT_HUGEPAGE_DEBUG_COW_FLAG mm/huge_memory.c: use helper function migration_entry_to_page() include/linux/huge_mm.h | 3 --- mm/huge_memory.c | 48 ++++++++++++++++++++--------------------- 2 files changed, 23 insertions(+), 28 deletions(-) -- 2.19.1