[PATCH v3 0/7] Rationalise __alloc_pages wrappers

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



I was poking around the __alloc_pages variants trying to understand
why they each exist, and couldn't really find a good justification for
keeping __alloc_pages and __alloc_pages_nodemask as separate functions.
That led to getting rid of alloc_pages_current() and then I noticed the
documentation was bad, and then I noticed the mempolicy documentation
wasn't included ...
anyway, this is all cleanups & doc fixes.

v3:
 - Added acks from Mike (patches 5 & 7) & Michel (patch 5)
 - Improved wording of return value (Mike, patch 5)
 - Added patch 6
v2:
 - Added acks from Vlastimil (patches 2-4) & Michel (patches 3-4)
 - Added patches 1, 5 and 7

Matthew Wilcox (Oracle) (7):
  mm/page_alloc: Rename alloc_mask to alloc_gfp
  mm/page_alloc: Rename gfp_mask to gfp
  mm/page_alloc: Combine __alloc_pages and __alloc_pages_nodemask
  mm/mempolicy: Rename alloc_pages_current to alloc_pages
  mm/mempolicy: Rewrite alloc_pages documentation
  mm/mempolicy: Rewrite alloc_pages_vma documentation
  mm/mempolicy: Fix mpol_misplaced kernel-doc

 Documentation/admin-guide/mm/transhuge.rst |  2 +-
 Documentation/core-api/mm-api.rst          |  1 +
 include/linux/gfp.h                        | 21 ++----
 mm/hugetlb.c                               |  2 +-
 mm/internal.h                              |  4 +-
 mm/mempolicy.c                             | 76 +++++++++-------------
 mm/migrate.c                               |  2 +-
 mm/page_alloc.c                            | 34 +++++-----
 8 files changed, 59 insertions(+), 83 deletions(-)

-- 
2.29.2





[Index of Archives]     [Linux ARM Kernel]     [Linux ARM]     [Linux Omap]     [Fedora ARM]     [IETF Annouce]     [Bugtraq]     [Linux OMAP]     [Linux MIPS]     [eCos]     [Asterisk Internet PBX]     [Linux API]

  Powered by Linux