On Sun, Sep 18, 2011 at 5:56 PM, Glauber Costa <glommer@xxxxxxxxxxxxx> wrote: > @@ -270,6 +274,10 @@ struct mem_cgroup { > */ > struct res_counter memsw; > /* > + * the counter to account for kmem usage. > + */ > + struct res_counter kmem; > + /* I don't see this charged, is this used in a later patch in this series? > @@ -5665,3 +5754,17 @@ static int __init enable_swap_account(char *s) > __setup("swapaccount=", enable_swap_account); > > #endif > + > +#ifdef CONFIG_CGROUP_MEM_RES_CTLR_KMEM > +static int __init disable_kmem_account(char *s) Minor nit. To be consistent with the other memcg __setup options, I think this should be renamed to enable_kmem_account(). > +{ > + /* consider enabled if no parameter or 1 is given */ > + if (!strcmp(s, "1")) > + do_kmem_account = 1; > + else if (!strcmp(s, "0")) > + do_kmem_account = 0; > + return 1; > +} > +__setup("kmemaccount=", disable_kmem_account); > + > +#endif -- To unsubscribe, send a message with 'unsubscribe linux-mm' in the body to majordomo@xxxxxxxxx. For more info on Linux MM, see: http://www.linux-mm.org/ . Fight unfair telecom internet charges in Canada: sign http://stopthemeter.ca/ Don't email: <a href