I was poking my way around the __alloc_pages variants trying to understand why they each exist, and couldn't really find a good justification for keeping __alloc_pages and __alloc_pages_nodemask as separate functions. Matthew Wilcox (Oracle) (2): mm/page-alloc: Rename gfp_mask to gfp mm: Combine __alloc_pages and __alloc_pages_nodemask Documentation/admin-guide/mm/transhuge.rst | 2 +- include/linux/gfp.h | 13 +++---------- mm/hugetlb.c | 2 +- mm/internal.h | 4 ++-- mm/mempolicy.c | 6 +++--- mm/migrate.c | 2 +- mm/page_alloc.c | 22 +++++++++++----------- 7 files changed, 22 insertions(+), 29 deletions(-) -- 2.29.2