On Wed, Jan 20, 2021 at 10:59:05AM +0100, Oscar Salvador wrote: > On Tue, Jan 19, 2021 at 05:30:46PM -0800, Mike Kravetz wrote: > > Use the new hugetlb page specific flag HPageMigratable to replace the > > page_huge_active interfaces. By it's name, page_huge_active implied > > that a huge page was on the active list. However, that is not really > > what code checking the flag wanted to know. It really wanted to determine > > if the huge page could be migrated. This happens when the page is actually > > added the page cache and/or task page table. This is the reasoning behind > > the name change. > > > > The VM_BUG_ON_PAGE() calls in the *_huge_active() interfaces are not > > really necessary as we KNOW the page is a hugetlb page. Therefore, they > > are removed. > > > > The routine page_huge_active checked for PageHeadHuge before testing the > > active bit. This is unnecessary in the case where we hold a reference or > > lock and know it is a hugetlb head page. page_huge_active is also called > > without holding a reference or lock (scan_movable_pages), and can race with > > code freeing the page. The extra check in page_huge_active shortened the > > race window, but did not prevent the race. Offline code calling > > scan_movable_pages already deals with these races, so removing the check > > is acceptable. Add comment to racy code. > > > > Signed-off-by: Mike Kravetz <mike.kravetz@xxxxxxxxxx> > > Hi Mike, > > This comment addresses both this patch and the next one. > > Instead of putting the SetHPageMigratable flag spread over the > allocation paths, would it make more sense to place it in > alloc_huge_page before returning the page? > Then we could opencode SetHPageMigratableIfSupported right there. and in putback_active_hugepage. -- Oscar Salvador SUSE L3