Re: [PATCH -v2 -mm] add extra free kbytes tunable

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On 09/01/2011 03:26 PM, Rik van Riel wrote:

> @@ -5123,6 +5135,7 @@ static void setup_per_zone_lowmem_reserve(void)
>  void setup_per_zone_wmarks(void)
>  {
>  	unsigned long pages_min = min_free_kbytes >> (PAGE_SHIFT - 10);
> +	unsigned long pages_low = extra_free_kbytes >> (PAGE_SHIFT - 10);

I think pages_extra is better name for this variable because pages_low is
calculated like following.

pages_low = pages_min + "pages_extra" + (pages_min >> 2)

>  	unsigned long lowmem_pages = 0;
>  	struct zone *zone;
>  	unsigned long flags;
> @@ -5134,11 +5147,14 @@ void setup_per_zone_wmarks(void)
>  	}
>  
>  	for_each_zone(zone) {
> -		u64 tmp;
> +		u64 min, low;

Same as above.

Thanks,
Satoru

--
To unsubscribe, send a message with 'unsubscribe linux-mm' in
the body to majordomo@xxxxxxxxx.  For more info on Linux MM,
see: http://www.linux-mm.org/ .
Fight unfair telecom internet charges in Canada: sign http://stopthemeter.ca/
Don't email: <a href


[Index of Archives]     [Linux ARM Kernel]     [Linux ARM]     [Linux Omap]     [Fedora ARM]     [IETF Annouce]     [Bugtraq]     [Linux]     [Linux OMAP]     [Linux MIPS]     [ECOS]     [Asterisk Internet PBX]     [Linux API]