On Fri, Jan 8, 2021 at 5:09 AM Walter Wu <walter-zh.wu@xxxxxxxxxxxx> wrote: > > CONFIG_KASAN_STACK and CONFIG_KASAN_STACK_ENABLE both enable KASAN stack > instrumentation, but we should only need one config, so that we remove > CONFIG_KASAN_STACK_ENABLE and make CONFIG_KASAN_STACK workable. see [1]. > > When enable KASAN stack instrumentation, then for gcc we could do > no prompt and default value y, and for clang prompt and default > value n. > > [1]: https://bugzilla.kernel.org/show_bug.cgi?id=210221 > > Signed-off-by: Walter Wu <walter-zh.wu@xxxxxxxxxxxx> > Suggested-by: Dmitry Vyukov <dvyukov@xxxxxxxxxx> > Cc: Andrey Ryabinin <aryabinin@xxxxxxxxxxxxx> > Cc: Dmitry Vyukov <dvyukov@xxxxxxxxxx> > Cc: Andrey Konovalov <andreyknvl@xxxxxxxxxx> > Cc: Alexander Potapenko <glider@xxxxxxxxxx> > Cc: Andrew Morton <akpm@xxxxxxxxxxxxxxxxxxxx> > Cc: Nathan Chancellor <natechancellor@xxxxxxxxx> > --- > > v2: make commit log to be more readable. > v3: remain CONFIG_KASAN_STACK_ENABLE setting > fix the pre-processors syntax > > --- > arch/arm64/kernel/sleep.S | 2 +- > arch/x86/kernel/acpi/wakeup_64.S | 2 +- > include/linux/kasan.h | 2 +- > lib/Kconfig.kasan | 8 ++------ > mm/kasan/common.c | 2 +- > mm/kasan/kasan.h | 2 +- > mm/kasan/report_generic.c | 2 +- > scripts/Makefile.kasan | 10 ++++++++-- > 8 files changed, 16 insertions(+), 14 deletions(-) > > diff --git a/arch/arm64/kernel/sleep.S b/arch/arm64/kernel/sleep.S > index 6bdef7362c0e..7c44ede122a9 100644 > --- a/arch/arm64/kernel/sleep.S > +++ b/arch/arm64/kernel/sleep.S > @@ -133,7 +133,7 @@ SYM_FUNC_START(_cpu_resume) > */ > bl cpu_do_resume > > -#if defined(CONFIG_KASAN) && CONFIG_KASAN_STACK > +#if defined(CONFIG_KASAN) && defined(CONFIG_KASAN_STACK) > mov x0, sp > bl kasan_unpoison_task_stack_below > #endif > diff --git a/arch/x86/kernel/acpi/wakeup_64.S b/arch/x86/kernel/acpi/wakeup_64.S > index 5d3a0b8fd379..c7f412f4e07d 100644 > --- a/arch/x86/kernel/acpi/wakeup_64.S > +++ b/arch/x86/kernel/acpi/wakeup_64.S > @@ -112,7 +112,7 @@ SYM_FUNC_START(do_suspend_lowlevel) > movq pt_regs_r14(%rax), %r14 > movq pt_regs_r15(%rax), %r15 > > -#if defined(CONFIG_KASAN) && CONFIG_KASAN_STACK > +#if defined(CONFIG_KASAN) && defined(CONFIG_KASAN_STACK) > /* > * The suspend path may have poisoned some areas deeper in the stack, > * which we now need to unpoison. > diff --git a/include/linux/kasan.h b/include/linux/kasan.h > index 5e0655fb2a6f..35d1e9b2cbfa 100644 > --- a/include/linux/kasan.h > +++ b/include/linux/kasan.h > @@ -302,7 +302,7 @@ static inline void kasan_kfree_large(void *ptr, unsigned long ip) {} > > #endif /* CONFIG_KASAN */ > > -#if defined(CONFIG_KASAN) && CONFIG_KASAN_STACK > +#if defined(CONFIG_KASAN) && defined(CONFIG_KASAN_STACK) > void kasan_unpoison_task_stack(struct task_struct *task); > #else > static inline void kasan_unpoison_task_stack(struct task_struct *task) {} > diff --git a/lib/Kconfig.kasan b/lib/Kconfig.kasan > index f5fa4ba126bf..fde82ec85f8f 100644 > --- a/lib/Kconfig.kasan > +++ b/lib/Kconfig.kasan > @@ -138,9 +138,10 @@ config KASAN_INLINE > > endchoice > > -config KASAN_STACK_ENABLE > +config KASAN_STACK > bool "Enable stack instrumentation (unsafe)" if CC_IS_CLANG && !COMPILE_TEST Does this syntax mean that KASAN_STACK is only present for CC_IS_CLANG? Or that it can only be disabled for CC_IS_CLANG? Anyway, I think it's better to 1. allow to control KASAN_STACK regardless of the compiler (as it was possible before), and 2. avoid this "bool ... if ..." syntax as it's confusing. > depends on KASAN_GENERIC || KASAN_SW_TAGS > + default y if CC_IS_GCC > help > The LLVM stack address sanitizer has a know problem that > causes excessive stack usage in a lot of functions, see > @@ -154,11 +155,6 @@ config KASAN_STACK_ENABLE > CONFIG_COMPILE_TEST. On gcc it is assumed to always be safe > to use and enabled by default. > > -config KASAN_STACK > - int > - default 1 if KASAN_STACK_ENABLE || CC_IS_GCC > - default 0 > - > config KASAN_SW_TAGS_IDENTIFY > bool "Enable memory corruption identification" > depends on KASAN_SW_TAGS > diff --git a/mm/kasan/common.c b/mm/kasan/common.c > index 38ba2aecd8f4..bf8b073eed62 100644 > --- a/mm/kasan/common.c > +++ b/mm/kasan/common.c > @@ -63,7 +63,7 @@ void __kasan_unpoison_range(const void *address, size_t size) > unpoison_range(address, size); > } > > -#if CONFIG_KASAN_STACK > +#ifdef CONFIG_KASAN_STACK > /* Unpoison the entire stack for a task. */ > void kasan_unpoison_task_stack(struct task_struct *task) > { > diff --git a/mm/kasan/kasan.h b/mm/kasan/kasan.h > index cc4d9e1d49b1..bdfdb1cff653 100644 > --- a/mm/kasan/kasan.h > +++ b/mm/kasan/kasan.h > @@ -224,7 +224,7 @@ void *find_first_bad_addr(void *addr, size_t size); > const char *get_bug_type(struct kasan_access_info *info); > void metadata_fetch_row(char *buffer, void *row); > > -#if defined(CONFIG_KASAN_GENERIC) && CONFIG_KASAN_STACK > +#if defined(CONFIG_KASAN_GENERIC) && defined(CONFIG_KASAN_STACK) > void print_address_stack_frame(const void *addr); > #else > static inline void print_address_stack_frame(const void *addr) { } > diff --git a/mm/kasan/report_generic.c b/mm/kasan/report_generic.c > index 8a9c889872da..4e16518d9877 100644 > --- a/mm/kasan/report_generic.c > +++ b/mm/kasan/report_generic.c > @@ -128,7 +128,7 @@ void metadata_fetch_row(char *buffer, void *row) > memcpy(buffer, kasan_mem_to_shadow(row), META_BYTES_PER_ROW); > } > > -#if CONFIG_KASAN_STACK > +#ifdef CONFIG_KASAN_STACK > static bool __must_check tokenize_frame_descr(const char **frame_descr, > char *token, size_t max_tok_len, > unsigned long *value) > diff --git a/scripts/Makefile.kasan b/scripts/Makefile.kasan > index 1e000cc2e7b4..abf231d209b1 100644 > --- a/scripts/Makefile.kasan > +++ b/scripts/Makefile.kasan > @@ -2,6 +2,12 @@ > CFLAGS_KASAN_NOSANITIZE := -fno-builtin > KASAN_SHADOW_OFFSET ?= $(CONFIG_KASAN_SHADOW_OFFSET) > > +ifdef CONFIG_KASAN_STACK > + stack_enable := 1 > +else > + stack_enable := 0 > +endif > + > ifdef CONFIG_KASAN_GENERIC > > ifdef CONFIG_KASAN_INLINE > @@ -27,7 +33,7 @@ else > CFLAGS_KASAN := $(CFLAGS_KASAN_SHADOW) \ > $(call cc-param,asan-globals=1) \ > $(call cc-param,asan-instrumentation-with-call-threshold=$(call_threshold)) \ > - $(call cc-param,asan-stack=$(CONFIG_KASAN_STACK)) \ > + $(call cc-param,asan-stack=$(stack_enable)) \ > $(call cc-param,asan-instrument-allocas=1) > endif > > @@ -42,7 +48,7 @@ else > endif > > CFLAGS_KASAN := -fsanitize=kernel-hwaddress \ > - -mllvm -hwasan-instrument-stack=$(CONFIG_KASAN_STACK) \ > + -mllvm -hwasan-instrument-stack=$(stack_enable) \ > -mllvm -hwasan-use-short-granules=0 \ > $(instrumentation_flags) > > -- > 2.18.0 > > -- > You received this message because you are subscribed to the Google Groups "kasan-dev" group. > To unsubscribe from this group and stop receiving emails from it, send an email to kasan-dev+unsubscribe@xxxxxxxxxxxxxxxx. > To view this discussion on the web visit https://groups.google.com/d/msgid/kasan-dev/20210108040940.1138-1-walter-zh.wu%40mediatek.com.