On Wed, Dec 09, 2020 at 12:57:38PM -0800, John Hubbard wrote: > > diff --git a/mm/gup.c b/mm/gup.c > > index 98eb8e6d2609c3..7b33b7d4b324d7 100644 > > +++ b/mm/gup.c > > @@ -123,6 +123,28 @@ static __maybe_unused struct page *try_grab_compound_head(struct page *page, > > return NULL; > > } > > +static void put_compound_head(struct page *page, int refs, unsigned int flags) > > +{ > > It might be nice to rename "page" to "head", here. > > While reading this I toyed with the idea of having this at the top: > > VM_BUG_ON_PAGE(compound_head(page) != page, page); > > ...but it's overkill in a static function with pretty clear call sites. So I > think it's just right as-is. Matt's folio patches would take are of this, when that is available all this becomes a lot better. Thanks, Jason