Oops, this one has some rebase errors, I'll send v7 soon. Sorry for the noise. On Mon, Nov 09, 2020 at 06:24:11PM +0200, Mike Rapoport wrote: > From: Mike Rapoport <rppt@xxxxxxxxxxxxx> > > Hi, > > During recent discussion about KVM protected memory, David raised a concern > about usage of __kernel_map_pages() outside of DEBUG_PAGEALLOC scope [1]. > > Indeed, for architectures that define CONFIG_ARCH_HAS_SET_DIRECT_MAP it is > possible that __kernel_map_pages() would fail, but since this function is > void, the failure will go unnoticed. > > Moreover, there's lack of consistency of __kernel_map_pages() semantics > across architectures as some guard this function with > #ifdef DEBUG_PAGEALLOC, some refuse to update the direct map if page > allocation debugging is disabled at run time and some allow modifying the > direct map regardless of DEBUG_PAGEALLOC settings. > > This set straightens this out by restoring dependency of > __kernel_map_pages() on DEBUG_PAGEALLOC and updating the call sites > accordingly. > > Since currently the only user of __kernel_map_pages() outside > DEBUG_PAGEALLOC is hibernation, it is updated to make direct map accesses > there more explicit. > > [1] https://lore.kernel.org/lkml/2759b4bf-e1e3-d006-7d86-78a40348269d@xxxxxxxxxx > > v6 changes: > * revert slab changes to avoid redundant check of static key > > v5 changes: > * use pairs of _map()/_unmap() functions instead of _map(..., int enable) as > Vlastimil suggested > https://lore.kernel.org/lkml/20201108065758.1815-1-rppt@xxxxxxxxxx > > v4 changes: > * s/WARN_ON/pr_warn_once/ per David and Kirill > * rebase on v5.10-rc2 > * add Acked/Reviewed tags > https://lore.kernel.org/lkml/20201103162057.22916-1-rppt@xxxxxxxxxx > > v3 changes: > * update arm64 changes to avoid regression, per Rick's comments > * fix bisectability > https://lore.kernel.org/lkml/20201101170815.9795-1-rppt@xxxxxxxxxx > > v2 changes: > * Rephrase patch 2 changelog to better describe the change intentions and > implications > * Move removal of kernel_map_pages() from patch 1 to patch 2, per David > https://lore.kernel.org/lkml/20201029161902.19272-1-rppt@xxxxxxxxxx > > v1: > https://lore.kernel.org/lkml/20201025101555.3057-1-rppt@xxxxxxxxxx > > Mike Rapoport (4): > mm: introduce debug_pagealloc_{map,unmap}_pages() helpers > PM: hibernate: make direct map manipulations more explicit > arch, mm: restore dependency of __kernel_map_pages() on DEBUG_PAGEALLOC > arch, mm: make kernel_page_present() always available > > arch/Kconfig | 3 +++ > arch/arm64/Kconfig | 4 +-- > arch/arm64/include/asm/cacheflush.h | 1 + > arch/arm64/mm/pageattr.c | 6 +++-- > arch/powerpc/Kconfig | 5 +--- > arch/riscv/Kconfig | 4 +-- > arch/riscv/include/asm/pgtable.h | 2 -- > arch/riscv/include/asm/set_memory.h | 1 + > arch/riscv/mm/pageattr.c | 31 ++++++++++++++++++++++ > arch/s390/Kconfig | 4 +-- > arch/sparc/Kconfig | 4 +-- > arch/x86/Kconfig | 4 +-- > arch/x86/include/asm/set_memory.h | 1 + > arch/x86/mm/pat/set_memory.c | 4 +-- > include/linux/mm.h | 40 ++++++++++++++--------------- > include/linux/set_memory.h | 5 ++++ > kernel/power/snapshot.c | 38 +++++++++++++++++++++++++-- > mm/memory_hotplug.c | 3 +-- > mm/page_alloc.c | 6 ++--- > 19 files changed, 113 insertions(+), 53 deletions(-) > > -- > 2.28.0 > -- Sincerely yours, Mike.