On Wed, Oct 28, 2020 at 11:56 AM Dmitry Vyukov <dvyukov@xxxxxxxxxx> wrote: > > On Thu, Oct 22, 2020 at 3:19 PM Andrey Konovalov <andreyknvl@xxxxxxxxxx> wrote: > > > > Tag-based KASAN modes are fully initialized with kasan_init_tags(), > > while the generic mode only requireds kasan_init(). Move the > > initialization message for tag-based modes into kasan_init_tags(). > > > > Also fix pr_fmt() usage for KASAN code: generic mode doesn't need it, > > Why doesn't it need it? What's the difference with tag modes? I need to reword the patch descriptions: it's not the mode that doesn't need it, it's the generic.c file, as it doesn't use any pr_*() functions. > > > tag-based modes should use "kasan:" instead of KBUILD_MODNAME. > > With generic KASAN I currently see: > > [ 0.571473][ T0] kasan: KernelAddressSanitizer initialized > > So KBUILD_MODNAME somehow works. Is there some difference between files? That code is printed from arch/xxx/mm/kasan_init*.c, which has its own pr_fmt defined. > > > Signed-off-by: Andrey Konovalov <andreyknvl@xxxxxxxxxx> > > Link: https://linux-review.googlesource.com/id/Idfd1e50625ffdf42dfc3dbf7455b11bd200a0a49 > > --- > > arch/arm64/mm/kasan_init.c | 3 +++ > > mm/kasan/generic.c | 2 -- > > mm/kasan/hw_tags.c | 4 ++++ > > mm/kasan/sw_tags.c | 4 +++- > > 4 files changed, 10 insertions(+), 3 deletions(-) > > > > diff --git a/arch/arm64/mm/kasan_init.c b/arch/arm64/mm/kasan_init.c > > index b6b9d55bb72e..8f17fa834b62 100644 > > --- a/arch/arm64/mm/kasan_init.c > > +++ b/arch/arm64/mm/kasan_init.c > > @@ -290,5 +290,8 @@ void __init kasan_init(void) > > { > > kasan_init_shadow(); > > kasan_init_depth(); > > +#if defined(CONFIG_KASAN_GENERIC) > > + /* CONFIG_KASAN_SW/HW_TAGS also requires kasan_init_tags(). */ > > A bit cleaner way may be to introduce kasan_init_early() and > kasan_init_late(). Late() will do tag init and always print the > message. It appears we'll also need kasan_init_even_later() for some MTE-related stuff. I'll try to figure out some sane naming scheme here and include it into the next version.