> From: Yanfei Xu <yanfei.xu@xxxxxxxxxxxxx> > > There are two 'start_pfn' declared in compact_zone() which have > different meaning. Rename the second one to 'iteration_start_pfn' > to prevent trace_mm_compaction_end() from tracing an undesirable > value. > > BTW, remove an useless semicolon. > > Acked-by: David Hildenbrand <david@xxxxxxxxxx> > Acked-by: Vlastimil Babka <vbabka@xxxxxxx> > Signed-off-by: Yanfei Xu <yanfei.xu@xxxxxxxxxxxxx> > --- > v1->v2: > Rename 'start_pfn' to 'iteration_start_pfn' and change commit messages. > > mm/compaction.c | 7 +++---- > 1 file changed, 3 insertions(+), 4 deletions(-) > > diff --git a/mm/compaction.c b/mm/compaction.c > index 176dcded298e..ccd27c739fd6 100644 > --- a/mm/compaction.c > +++ b/mm/compaction.c > @@ -2272,7 +2272,7 @@ compact_zone(struct compact_control *cc, struct capture_control *capc) > > while ((ret = compact_finished(cc)) == COMPACT_CONTINUE) { > int err; > - unsigned long start_pfn = cc->migrate_pfn; > + unsigned long iteration_start_pfn = cc->migrate_pfn; > > /* > * Avoid multiple rescans which can happen if a page cannot be > @@ -2284,7 +2284,7 @@ compact_zone(struct compact_control *cc, struct capture_control *capc) > */ > cc->rescan = false; > if (pageblock_start_pfn(last_migrated_pfn) == > - pageblock_start_pfn(start_pfn)) { > + pageblock_start_pfn(iteration_start_pfn)) { > cc->rescan = true; > } > > @@ -2308,8 +2308,7 @@ compact_zone(struct compact_control *cc, struct capture_control *capc) > goto check_drain; > case ISOLATE_SUCCESS: > update_cached = false; > - last_migrated_pfn = start_pfn; > - ; > + last_migrated_pfn = iteration_start_pfn; > } > > err = migrate_pages(&cc->migratepages, compaction_alloc, Improves readability. Acked-by: Pankaj Gupta <pankaj.gupta.linux@xxxxxxxxx>