Hi, (added Mel) On Wed, Sep 16, 2020 at 01:01:18PM +0200, mateusznosek0@xxxxxxxxx wrote: > From: Mateusz Nosek <mateusznosek0@xxxxxxxxx> > > The 'finalise_ac' function is just 'epilogue' for 'prepare_alloc_pages'. > Therefore there is no need to keep them both so 'finalise_ac' content can > be merged into 'prepare_alloc_pages' code. It would make > '__alloc_pages_nodemask' cleaner when it comes to readability. These functions were split from alloc_pages_nodemask() by commit 9cd7555875bb ("mm, page_alloc: split alloc_pages_nodemask()"), so at the very least I'd add Mel to 'cc. > Signed-off-by: Mateusz Nosek <mateusznosek0@xxxxxxxxx> > --- > mm/page_alloc.c | 10 ++-------- > 1 file changed, 2 insertions(+), 8 deletions(-) > > diff --git a/mm/page_alloc.c b/mm/page_alloc.c > index b9bd75cacf02..a094e297c88f 100644 > --- a/mm/page_alloc.c > +++ b/mm/page_alloc.c > @@ -4824,12 +4824,6 @@ static inline bool prepare_alloc_pages(gfp_t gfp_mask, unsigned int order, > > *alloc_flags = current_alloc_flags(gfp_mask, *alloc_flags); > > - return true; > -} > - > -/* Determine whether to spread dirty pages and what the first usable zone */ > -static inline void finalise_ac(gfp_t gfp_mask, struct alloc_context *ac) > -{ > /* Dirty zone balancing only done in the fast path */ > ac->spread_dirty_pages = (gfp_mask & __GFP_WRITE); > > @@ -4840,6 +4834,8 @@ static inline void finalise_ac(gfp_t gfp_mask, struct alloc_context *ac) > */ > ac->preferred_zoneref = first_zones_zonelist(ac->zonelist, > ac->highest_zoneidx, ac->nodemask); > + > + return true; > } > > /* > @@ -4868,8 +4864,6 @@ __alloc_pages_nodemask(gfp_t gfp_mask, unsigned int order, int preferred_nid, > if (!prepare_alloc_pages(gfp_mask, order, preferred_nid, nodemask, &ac, &alloc_mask, &alloc_flags)) > return NULL; > > - finalise_ac(gfp_mask, &ac); > - > /* > * Forbid the first pass from falling back to types that fragment > * memory until all local zones are considered. > -- > 2.20.1 > > -- Sincerely yours, Mike.